Post by Brojbeanu » Wed Feb 02, 2022 9:37 pm

Hello,
Immediately after I installed Opencart 3.0.3.8 which I downloaded today 02.02.2022, I had 2 errors: one was related to an error in the product.php file row 45 in the catalog \ model \ catalog folder that I have solved it and another being the following: Unknown: mysqli::real_escape_string(): Passing null to parameter #1 ($string) of type string is deprecated in D:\wamp64\www\......\system\library\db\mysqli.php on line 53
Can somebody help me?
I use php 8.1.2 and mysql 8.0.28.

Newbie

Posts

Joined
Fri Aug 14, 2020 1:06 am

Post by mikeinterserv » Wed Feb 02, 2022 10:31 pm

Brojbeanu wrote:
Wed Feb 02, 2022 9:37 pm
Hello,
Immediately after I installed Opencart 3.0.3.8 which I downloaded today 02.02.2022, I had 2 errors: one was related to an error in the product.php file row 45 in the catalog \ model \ catalog folder that I have solved it and another being the following: Unknown: mysqli::real_escape_string(): Passing null to parameter #1 ($string) of type string is deprecated in D:\wamp64\www\......\system\library\db\mysqli.php on line 53
Can somebody help me?
I use php 8.1.2 and mysql 8.0.28.
Use php 7.4
or look into the fixes etc required to run php 8.0

Active Member

Posts

Joined
Thu May 28, 2020 6:55 am
Location - Wales

Post by Brojbeanu » Thu Feb 03, 2022 4:46 am

Where can I find fixes etc documentații?

Newbie

Posts

Joined
Fri Aug 14, 2020 1:06 am

Post by xxvirusxx » Thu Feb 03, 2022 4:57 am

Better use PHP 7.4.
There are not fixes yet for PHP 8.1

My Converted Modules | Opencart Upgrade Service | Free Dashboard Maps | Buy me a beer | My Custom OC 3.0.3.8


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Surge-blade » Mon Mar 14, 2022 6:31 am

Hi, I have Opencart Version 3.0.3.8 and PHP Version 7.4.28 , and i have the same problem, Every thing works fine, the ONLY problem is I can't select region/state for registering,guest checkout, cart checkout, or adding an address. This one thing is stopping me. Its only the region/state selector, It doesn't even say "please select". even if i make a replacement region/state field it doesn't work? If anyone could help, i would appreciate it.

Newbie

Posts

Joined
Mon Mar 14, 2022 6:04 am

Post by ADD Creative » Tue Mar 15, 2022 7:11 pm

Surge-blade wrote:
Mon Mar 14, 2022 6:31 am
Hi, I have Opencart Version 3.0.3.8 and PHP Version 7.4.28 , and i have the same problem, Every thing works fine, the ONLY problem is I can't select region/state for registering,guest checkout, cart checkout, or adding an address. This one thing is stopping me. Its only the region/state selector, It doesn't even say "please select". even if i make a replacement region/state field it doesn't work? If anyone could help, i would appreciate it.
The original poster issue was due to using PHP 8.1. You are probably best to start your own topic giving as much detail as possible, such as theme used, extensions used, link to your site, any errors in the server/PHP errors logs, any errors in your OpenCart error logs and any errors in your web browser's developer tool console.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by ozdeozgu@yahoo.com » Sun Jun 19, 2022 5:44 pm

I had the same problem with opencart 3.0.3.8 and php 8.X and then I changed to PHP 7.4 and now there is no problem Elhamdülillah.


Posts

Joined
Fri Nov 06, 2020 3:43 pm
Who is online

Users browsing this forum: No registered users and 4 guests