Post by comprido » Fri May 25, 2018 5:00 am

I've installed Amazon Pay and Login with Amazon from isenselabs.com that is not offering support:
https://www.opencart.com/index.php?rout ... n_id=33206

Hi, I've recently integrated the module in Opencart 1.5.6.1 and configure it following the steps they provide on the package/link.

The problem is once signed in, the module/customer cannot validate a valid shipping address on the checkout, just when the shipping method is not based on weight, Login and Pay with Amazon made is job as expected.

Anyone with the same issue?

ERROR: There are no shipping options to the selected address. Please select a different shipping address.
OPENCART VERSION: 1.5.6.1

I've tried to change the weight unit as maybe from Seller Central is not matching but it doesn't work.

Pedro Martin - websitesbuilder.com.au
Checkout my free extensions: https://www.opencart.com/index.php?rout ... r=comprido


User avatar
New member

Posts

Joined
Mon Sep 10, 2012 11:46 pm

Post by comprido » Fri May 25, 2018 10:17 am

After literally 6h checking code and how the module migrate the addresses to OC database I detected the error in my Amazon profile where they have a field called "State/Province" >>> if you put there your (Spain) Province/State (zone_id) your opencart module will read it correctly.
Last edited by comprido on Sat Sep 14, 2019 10:31 pm, edited 2 times in total.

Pedro Martin - websitesbuilder.com.au
Checkout my free extensions: https://www.opencart.com/index.php?rout ... r=comprido


User avatar
New member

Posts

Joined
Mon Sep 10, 2012 11:46 pm

Post by olfactorymaven » Sat Sep 14, 2019 6:52 am

I’m glad I Searched and found this. I too ran into the same problem yesterday. I have 2.3.0.2 version. After iSenseLabs assisted with the QuickFix, the AmazonPay module worked. But the address is the issue at checkout.

When you say, Amazon profile, do you mean on Amazon’s platform or in the OpenCart admin?

Active Member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by comprido » Sat Sep 14, 2019 10:31 pm

olfactorymaven wrote:
Sat Sep 14, 2019 6:52 am
I’m glad I Searched and found this. I too ran into the same problem yesterday. I have 2.3.0.2 version. After iSenseLabs assisted with the QuickFix, the AmazonPay module worked. But the address is the issue at checkout.

When you say, Amazon profile, do you mean on Amazon’s platform or in the OpenCart admin?
Sorry about my english, mate.
Corrected: I detected the error in my Amazon profile where they have a field called "State/Province" >>> if you put there your (Spain) Province/State (zone_id) your opencart module will read it correctly.

Pedro Martin - websitesbuilder.com.au
Checkout my free extensions: https://www.opencart.com/index.php?rout ... r=comprido


User avatar
New member

Posts

Joined
Mon Sep 10, 2012 11:46 pm

Post by olfactorymaven » Mon Sep 16, 2019 2:43 am

Thank you 😊

Active Member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by olfactorymaven » Mon Sep 16, 2019 9:21 pm

Hey there, Pedro, I don't see the State option anywhere. On another note, the first warning is gone. Now, I get this when clicking on the gold button. Was this the error you were receiving?

Attachments

Screen Shot 2019-09-16 at 9.19.47 AM.png

Screen Shot 2019-09-16 at 9.19.47 AM.png (45.83 KiB) Viewed 1591 times


Active Member

Posts

Joined
Fri Apr 19, 2013 3:35 am


Post by olfactorymaven » Mon Sep 16, 2019 9:52 pm

I took the extension out of Sandbox mode. The problem is corrected. There’s another issue now, but thanks for your reply.

Active Member

Posts

Joined
Fri Apr 19, 2013 3:35 am

Who is online

Users browsing this forum: No registered users and 7 guests