Post by contact-technique » Wed Jun 13, 2018 7:54 pm

Hello,

Just a word to try to find some help.. I bought Live Theme Editor, last version, for Opencart 3.0.2.0 and my problems are :

- When I am try to modify anything, nothing happen
- When I try to save, anyway if nothing change, the progress bar start and.. over and over, inifinite loading..

I tryed solution founded here, but I am not in the same case (my config.php is OK) and try also solution to install, refresh cache etc.. but, same problem.

I am trying to contact viethemes support since 2 weeks (by website or directly by mail), nobody answer me.

So, please, can somebody provide some help here ?

Many thanks !


Posts

Joined
Sun Apr 29, 2018 7:47 am

Post by IP_CAM » Thu Jun 14, 2018 2:10 am

Well, he might be on vacation, but since this is a paid Extension,
as I recall, no-one else would be able to assist, and you could not
even legally publish such Code around here ... :-\ that's the problem.
But if you bought this extension trough the official OC Channels, you
could contact OC headquarters, to make sure, that Viethemes is still alive
and well, and that he care's about.

BUT, be aware, that this Extension might only work with DEFAULT OC like
built Theme Extensions, but not with PAVO/JOURNAL/e.t.c. Extensions,
because such Themes have nothing in common, technically, with OC Design
Standards. So, better don't write to OC, if you use such a Theme ... :P
Good Luck !
Ernie
PS. Some might contact you by PM, offering to assist, but just be careful,
and don't share any 'keys' or open any 'doors' to unknown individuals... :'(

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by julian70400 » Fri Jun 15, 2018 4:11 pm

Hello,

First, thanks for your answer !

Well, I am playing with Opencart only since one month, I not really have a good knowledge of this product, so I might have not done things correctly..

You show me an interesting point : this extension work only with original theme. Thing very interesting are :

- The extension WORK with a "test" theme (which I select in "theme" extension). In fact, extension works fine with all themes which I created, exept the default one :(
- When I try to apply a CSS modification directly in the code, it do not work. In fact, If I select my "test" theme, my modification is not shown, but it seem to appear in the default one !

I think there is a misconfigurating thing somewhere.. Not sure about Live Theme Editor implication in this case. My files may be wrong somewhere.. Can you help me to etablish a diag ? Where I must search ?

Newbie

Posts

Joined
Thu Jun 14, 2018 10:44 pm

Post by IP_CAM » Sat Jun 16, 2018 1:00 am

When I try to apply a CSS modification directly in the code, it do not work.
Well, I applied masses of CSS-Modifications directly into the corresponding Stylesheet, or
then into the Template File itself, and AFTER I cleared out all my Cache Sections, it always
worked well, at least, if I placed that Code into the correct Place. :D
---
But if you work with Extensions, VqMod and/or OcMod, you have to be aware of, what those
Override-Functions are doing in the first place.
A SEARCH Command line always looks for an ANCHOR/TAG, in a File, to be changed, by either
adding, replacing, or removing something, before, instead of, or after this Anchor/Tag Line.

And this ANCHOR/TAG must be written EXACTLY in the way, as it exists in a Theme Source File,
to make the OcMod/VqMod Routine work.

It's like using the wrong key, if you want to open a Door, if the key don't match, the Door won't open.
And if you use different Themes, you have to make sure, that such an ANCHOR/TAG will look exactly
the same, in the corresponding Theme Files, in order to do it's Job, or then, it won't do it's Job.
---
Let's use a simple sample, like in an OC-3 product.twig File:
<div class="col-sm-10">{{ description }}</div>
If this Line would, in a different Theme, be written like this:
<div class="col-sm-10">{{ description }} </div>
an Extension, looking for the first Line shown above, would NO LONGER
find, what is shown in the second sample line, because of , in this Case, the
EMPTY WHITESPACE GAP before the </div>
---
And to avoid such problems, an OcMod/VqMod might require Theme-specific
Sections and Routines, actually doing the same, but each one for it's specific
Theme, like, in a Case, where <div class="col-sm-10">{{ description }} ...
would have to be replaced by a somehow different (Product Description) layout:

Code: Select all

<search position="replace">
<![CDATA[<div class="col-sm-10">{{ description }}</div>]]></search>
<add trim="true">
...
...
AND:

Code: Select all

<search position="replace">
<![CDATA[<div class="col-sm-10">{{ description }} </div>]]></search>
<add trim="true">
...
...
then, the Extension would function on both Themes!

You see, it's not quite that easy, if one leaves the strict DEFAULT File/Theme Road.
But OC is an open Software, there are no rules, wich have to be followed, on how
to build OC Themes. Just compare it with Car's, there are no rules on Wheel Sizes,
that's why so many different Tire Sizes exist, and if one buys the wrong Size Tires,
it's sure not the Car Manufacturers Fault ... :laugh:
Good Luck! ;)
Ernie
--
PS. But, by all Logics, I would make it look the same, in both Themes, if it only would
be such a minor difference, instead of creating an additional VqMod/OcMod routine! :laugh: :crazy:

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by julian70400 » Mon Jun 18, 2018 5:55 pm

THanks for your help.

How can I know if I use an other motor (vqmod or something else) I did never install nothing else than extension through ocmod.

Newbie

Posts

Joined
Thu Jun 14, 2018 10:44 pm
Who is online

Users browsing this forum: No registered users and 6 guests