Page 1 of 12

Official Opencart v2.3.0.2 bug reports

Posted: Mon Aug 01, 2016 9:50 pm
by straightlight
This will be the official Opencart v2.3.0.2 bug reports topic to report any issues from the core.

LIST OF CONFIRMED BUGS AND SOLUTIONS:
BUG: Deleting a language causes Error: Table banner_image_description doesn't exist

FIX (4722):
- EDIT: admin/model/localisation/language.php
- CHANGE (line 222):
from:

Code: Select all

$this->db->query("DELETE FROM " . DB_PREFIX . "banner_image_description WHERE language_id = '" . (int)$language_id . "'");
to:

Code: Select all

$this->db->query("DELETE FROM " . DB_PREFIX . "banner_image WHERE language_id = '" . (int)$language_id . "'");
BUG: Error: Could not load model total!

Two-part bug. Part one: Event Compatibility cuts off too many parts of the route when trying to load the older extension format. ex. "extension/total/sub_total/getTotal" route gets turned into "total/sub_total" instead of "total/sub_total/getTotal". This causes it to try and load a model with no name throwing the exception. Part Two, this compatibility is being loaded fine when the route is "extension/total/subtotal" but is also loading when the route is "extension/total/sub_total/getTotal". I think this event should not be triggered for compatibility because it is a getTotal is a function call, not a model load. This causes the verification to fail and try to load the 2.2.x version which has other bits missing and throws different errors. Haven't figured out why the function call is going down the event path. But basically the attempt to support backwards compatibility with 2.2 mods is causing problems.

2 Solutions

FIX 1: Give up on 2.2.x compatibility and delete the following left-over folders:

Code: Select all

    catalog/model/total
    catalog/model/payment
    catalog/controller/payment
    catalog/model/shipping
    catalog/controller/module
    admin/controller/total
    admin/controller/payment
    admin/controller/shipping
    admin/controller/module
FIX 2: Add a hack to bypass the event when the function call for "getTotal", "getMethod", or "getQuote" are passed in. This is experimental but should at least restore support for 2.2.x mods for now. This is NOT a permanent fix. Just a work around.
EDIT: catalog/controller/event/compatibility.php
FIND:

Code: Select all

'model/' . $route. '.php'
REPLACE WITH:

Code: Select all

'model/' . ((strpos($route,'get') !== false) ? dirname($route) : $route) . '.php'
This should let routes like "extension/total/sub_total" work but block "extension/total/sub_total/getTotal" calls which fail on the directory check.
BUG: When enabled, fraud modules cause an error to be thrown during order completion, which can prevent the order from being fully completed. The error message thrown is: "Call to a member function check() on a non-object in /catalog/model/checkout/order.php"

FIX: http://forum.opencart.com/viewtopic.php ... 93#p638230

List of confirmed previous fixes that wasn't added from v2.2.0.0 release:

- Missing checkout 1st part validation process: http://forum.opencart.com/viewtopic.php ... 29#p617203

- Shipping checkout address fix: http://forum.opencart.com/viewtopic.php ... 59#p625959

- Admin orders customer notification email fix: http://forum.opencart.com/viewtopic.php ... 56#p632395

- Bugfix by artcore: http://forum.opencart.com/viewtopic.php ... 20#p632732

PHP Version issue

Posted: Tue Aug 02, 2016 12:42 am
by visual
Hi all.

I am migrating over to Opencart from Zencart and I have downloaded version 2.3.0.1 .. I have uploaded it to my server and there is a PHP version issue :(

I am running PHP Version 5.3.27 on the server and the message I am getting when I browse to the install is it requires version 5.4 ?

So ... can someone please advise a Opencart build that is compatible with my PHP version ? .. I have looked at the download requirements and on there it is stating 5.3+

I await your response.

Kind regards

After upgrade to 2.3.0.2 -> blank screen

Posted: Tue Aug 02, 2016 12:49 am
by mbeerli
FTP of files worked great,
Upgrade of DB seemed to work
Admin pages seem fine, all pages show up, dashboard, products and so on.
But main page homepage is blank.

Any suggestions?
Something strange:
If I delete config.php and replace with an empty file
the site trys to load for a while and the URL shows
<domain>/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/index.php

Re: After upgrade to 2.3.0.2 -> blank screen

Posted: Tue Aug 02, 2016 1:45 am
by straightlight
mbeerli wrote:FTP of files worked great,
Upgrade of DB seemed to work
Admin pages seem fine, all pages show up, dashboard, products and so on.
But main page homepage is blank.

Any suggestions?
Something strange:
If I delete config.php and replace with an empty file
the site trys to load for a while and the URL shows
<domain>/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/index.php
Followed is the Essentials topic: http://forum.opencart.com/viewtopic.php?f=190&t=165636 . See the: Error Logs - Alternative Ways of Access section of the forum so to report what is behind the blank pages.

Re: PHP Version issue

Posted: Tue Aug 02, 2016 1:50 am
by straightlight
visual wrote:Hi all.

I am migrating over to Opencart from Zencart and I have downloaded version 2.3.0.1 .. I have uploaded it to my server and there is a PHP version issue :(

I am running PHP Version 5.3.27 on the server and the message I am getting when I browse to the install is it requires version 5.4 ?

So ... can someone please advise a Opencart build that is compatible with my PHP version ? .. I have looked at the download requirements and on there it is stating 5.3+

I await your response.

Kind regards
Opencart v2.3.0.1 has been decommissioned by the OC developers. I would rather suggest to use the v2.3.0.2 release instead. If the error message persist, can you post the exact error message that you see afterwards?

Re: PHP Version issue

Posted: Tue Aug 02, 2016 1:58 am
by visual
Many thanks for your response straightlight :)

I am taking your advice and downloading the latest version to try it again. If it works .. I will update you here.

Basically .. I uploaded to my server and targetted the domain, going to the "install" directory. The webpage just gave me a text response saying "PHP version 5.4 required" .. I hope this explains it, if it happens again this time .. I will post a screenshot of the response.

Re: PHP Version issue

Posted: Tue Aug 02, 2016 2:02 am
by straightlight
visual wrote:Many thanks for your response straightlight :)

I am taking your advice and downloading the latest version to try it again. If it works .. I will update you here.

Basically .. I uploaded to my server and targetted the domain, going to the "install" directory. The webpage just gave me a text response saying "PHP version 5.4 required" .. I hope this explains it, if it happens again this time .. I will post a screenshot of the response.
No problem. However, I have moved your posts in this section regarding the latest version of Opencart. As for PHP v5.4 required, it might be possible that new server requirements may have been taken in effect in order to run the latest version. I would suggest to contact your host to make the proper adjustments with your PHP version installed with your domain.

Re: Official Opencart v2.3.0.2 bug reports

Posted: Tue Aug 02, 2016 4:48 am
by straightlight
@visual: Since this issue is rather related to host configuration than the OC platform, I will bring your last statements back to the original posting. Thanks for your feedback.

http error 500

Posted: Tue Aug 02, 2016 5:05 am
by rikn78
Hi,
I have just upgraded from opencart 2.2 to 2.2.0.3 and when I open the storefront I get a blank page with http error 500 on it. I have logged the error below but have no idea what it all means or where to start. Any suggestions please?

Re: http error 500

Posted: Tue Aug 02, 2016 5:14 am
by straightlight
rikn78 wrote:Hi,
I have just upgraded from opencart 2.2 to 2.2.0.3 and when I open the storefront I get a blank page with http error 500 on it. I have logged the error below but have no idea what it all means or where to start. Any suggestions please?
Opencart v2.2.0.3 does not exist but rather the latest version of v2.3.0.2 release. The error you're having means that the order total modules files was not moved to the new folders which are the new architectural ways to develop extensions and modules nowadays. More information for the structural paths to use can be found here: http://forum.opencart.com/viewtopic.php?f=183&t=165958

Re: Official Opencart v2.3.0.2 bug reports

Posted: Tue Aug 02, 2016 11:35 am
by superbrands
OpenCart v2.3.0.2, Fresh Install, Localhost, XAMPP

Action: Delete Language

Error: Table banner_image_description doesn't exist

Re: http error 500

Posted: Tue Aug 02, 2016 3:10 pm
by opencartArab
rikn78 wrote:Hi,
I have just upgraded from opencart 2.2 to 2.2.0.3 and when I open the storefront I get a blank page with http error 500 on it. I have logged the error below but have no idea what it all means or where to start. Any suggestions please?
remove this folders:

Code: Select all

catalog/model/feed
catalog/model/fraud
catalog/model/module
catalog/model/openbay
catalog/model/payment
catalog/model/shipping
catalog/model/total

Re: http error 500

Posted: Tue Aug 02, 2016 6:09 pm
by straightlight
opencartArab wrote:
rikn78 wrote:Hi,
I have just upgraded from opencart 2.2 to 2.2.0.3 and when I open the storefront I get a blank page with http error 500 on it. I have logged the error below but have no idea what it all means or where to start. Any suggestions please?
remove this folders:

Code: Select all

catalog/model/feed
catalog/model/fraud
catalog/model/module
catalog/model/openbay
catalog/model/payment
catalog/model/shipping
catalog/model/total
Do NOT follow this instruction straightforward. Ensure to backup your previous extensions before doing so as these folders can contain other extensions others than what the core delivers !

Then, follow these instructions to convert the paths so for the new version of Opencart to load your extensions accordingly: http://forum.opencart.com/viewtopic.php?f=183&t=165958

Re: Official Opencart v2.3.0.2 bug reports

Posted: Tue Aug 02, 2016 6:47 pm
by opencartArab
+1

Re: After upgrade to 2.3.0.2 -> blank screen

Posted: Tue Aug 02, 2016 7:57 pm
by Qphoria
mbeerli wrote:FTP of files worked great,
Upgrade of DB seemed to work
Admin pages seem fine, all pages show up, dashboard, products and so on.
But main page homepage is blank.

Any suggestions?
Something strange:
If I delete config.php and replace with an empty file
the site trys to load for a while and the URL shows
<domain>/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/index.php
Blank page issues can usually be resolved like this:
http://forum.opencart.com/viewtopic.php?f=170&t=50555

The endless install/install/install loop is usually caused by htaccess redirect settings. Try disabling htaccess while installing.

Re: Official Opencart v2.3.0.2 bug reports

Posted: Tue Aug 02, 2016 11:56 pm
by kermit627
Upgraded from 2.0.3.1 to 2.3.0.2 - any assistance is greatly appreciated.

After upgrading this is the error code i'm receiving:
Warning: require(/homepages/13/d561807322/htdocs/arcadeshop/catalog/language/en-gb/common/footer.php): failed to open stream: Permission denied in /homepages/13/d561807322/htdocs/arcadeshop/system/library/language.php on line 49
Fatal error: require(): Failed opening required '/homepages/13/d561807322/htdocs/arcadeshop/catalog/language/en-gb/common/footer.php' (include_path='.:/usr/lib/php5.5') in /homepages/13/d561807322/htdocs/arcadeshop/system/library/language.php on line 49

Re: Official Opencart v2.3.0.2 bug reports

Posted: Wed Aug 03, 2016 1:14 am
by Qphoria
kermit627 wrote:Upgraded from 2.0.3.1 to 2.3.0.2 - any assistance is greatly appreciated.

After upgrading this is the error code i'm receiving:
Warning: require(/homepages/13/d561807322/htdocs/arcadeshop/catalog/language/en-gb/common/footer.php): failed to open stream: Permission denied in /homepages/13/d561807322/htdocs/arcadeshop/system/library/language.php on line 49
Fatal error: require(): Failed opening required '/homepages/13/d561807322/htdocs/arcadeshop/catalog/language/en-gb/common/footer.php' (include_path='.:/usr/lib/php5.5') in /homepages/13/d561807322/htdocs/arcadeshop/system/library/language.php on line 49
Not sure. Seems like some sort of permissions thing. Does the file catalog/language/en-gb/common/footer.php exist and can you edit it in ftp normally?

Re: Official Opencart v2.3.0.2 bug reports

Posted: Wed Aug 03, 2016 1:47 am
by kermit627
Upgraded from 2.0.3.1 to 2.3.0.2. admin works. i've looked at the fix for this but not exactly sure what i need to do. any and all help is greatly appreciated.

My error message is :
Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /homepages/13/d561807322/htdocs/arcadeshop/system/engine/loader.php:169 Stack trace: #0 [internal function]: Loader->{closure}(Array, Array) #1 /homepages/13/d561807322/htdocs/arcadeshop/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array) #2 /homepages/13/d561807322/htdocs/arcadeshop/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array) #3 /homepages/13/d561807322/htdocs/arcadeshop/catalog/controller/common/cart.php(37): Proxy->getTotal(Array) #4 [internal function]: ControllerCommonCart->index(Array) #5 /homepages/13/d561807322/htdocs/arcadeshop/system/engine/action.php(51): call_user_func_array(Array, Array) #6 /homepages/13/d561807322/htdocs/arcadeshop/system/engine/loader.php(24): Action->execute(Object(Registry), Array) #7 /homepages/13/d561807322/htdocs/arcadeshop/catalog/controller/common/header.php(129): Loader->controller('common/cart') #8 [internal function]: ControllerCommonH in /homepages/13/d561807322/htdocs/arcadeshop/system/engine/loader.php on line 169

Re: Official Opencart v2.3.0.2 bug reports

Posted: Wed Aug 03, 2016 1:49 am
by kermit627
fixed this problem now the newest problem is in my last post. sorry for the multiple postings.

Qphoria wrote:
kermit627 wrote:Upgraded from 2.0.3.1 to 2.3.0.2 - any assistance is greatly appreciated.

After upgrading this is the error code i'm receiving:
Warning: require(/homepages/13/d561807322/htdocs/arcadeshop/catalog/language/en-gb/common/footer.php): failed to open stream: Permission denied in /homepages/13/d561807322/htdocs/arcadeshop/system/library/language.php on line 49
Fatal error: require(): Failed opening required '/homepages/13/d561807322/htdocs/arcadeshop/catalog/language/en-gb/common/footer.php' (include_path='.:/usr/lib/php5.5') in /homepages/13/d561807322/htdocs/arcadeshop/system/library/language.php on line 49
Not sure. Seems like some sort of permissions thing. Does the file catalog/language/en-gb/common/footer.php exist and can you edit it in ftp normally?

Re: Official Opencart v2.3.0.2 bug reports

Posted: Wed Aug 03, 2016 1:53 am
by straightlight
This issue has been reported on the first page of this topic: http://forum.opencart.com/viewtopic.php ... 12#p631768 . This is caused by a invalid path for the extension / module to be loaded. The solution has also been provided.