Post by dragonfly-ie » Sun Jun 19, 2016 12:40 am

Is there a fix to stop WARNING/POP-UP on index page with SSL? (clean 2.2.)
The page at https://yoursite.com/ contains a form which targets an insecure URL http://yoursite.com/common/currency/currency.

line 41 index-page: <form action="http://yoursite.com/common/currency/currency" method="post" enctype="multipart/form-data" id="form-currency">
When site visitor selects other than default currency, browser will warn that it is sending a non-secure form, and visitor has to allow it. - Not great for customer confidence!
???

“May the best day of your past be the worst day of your future.”


User avatar
New member

Posts

Joined
Sat Nov 09, 2013 2:31 am
Location - 52°N 7°37'W

Post by dragonfly-ie » Tue Jun 21, 2016 7:11 am


“May the best day of your past be the worst day of your future.”


User avatar
New member

Posts

Joined
Sat Nov 09, 2013 2:31 am
Location - 52°N 7°37'W

Post by Johnathan » Wed Jun 22, 2016 5:44 am

This line is the /catalog/controller/common/currency.php file is what determines that form link:

Code: Select all

$data['action'] = $this->url->link('common/currency/currency', '', $this->request->server['HTTPS']);
It could be that the server HTTPS value is not reading properly in your installation. You can try making that line look like this, which should make it always use SSL in OpenCart 2.2:

Code: Select all

$data['action'] = $this->url->link('common/currency/currency', '', true);

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by straightlight » Wed Jun 22, 2016 7:11 pm


The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by integris » Fri Jun 24, 2016 1:01 am

This currency fix didn't work for me. I ended up removing the code from the currency tpl /view/common/currency.tpl
Finally, got https/www working accross the site/products/catagories/checkout. I listed the steps in anwer a similar question here: http://stackoverflow.com/questions/3627 ... t/37996993

Newbie

Posts

Joined
Wed May 18, 2016 4:14 am

Post by dragonfly-ie » Fri Jun 24, 2016 5:30 pm

Thanks for all your replies.

Unfortunately @Jonathan's fix didn't work for me either.

On the other side, it seems to be browser specific, because I don't get warning/pop-up in Chrome nor Firefox.

“May the best day of your past be the worst day of your future.”


User avatar
New member

Posts

Joined
Sat Nov 09, 2013 2:31 am
Location - 52°N 7°37'W
Who is online

Users browsing this forum: No registered users and 7 guests