Post by Wifialarm » Thu Jan 28, 2016 6:27 pm

Hi all!

I'm still can't resolve that error -

OC with default theme, but now customers complaint, that they got this blank page (500 server error)

It appears, when customer log into shop and then choose to view order history. blank page is on address "index.php?route=account/order"

Can you help me?

Newbie

Posts

Joined
Sun Oct 25, 2015 5:56 pm

Post by labeshops » Thu Jan 28, 2016 9:13 pm

A blank page means something is not completing. Did you check your error logs or turn show errors to on temporarily and view that page yourself and see what it says?

Do you have any mods that are supposed to run on that page? If so, disable them and check it again.

Running Opencart v3.0.3.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by Wifialarm » Thu Jan 28, 2016 10:30 pm

Yes, I can produce the same error and I saw it.

In error list is this:
Image

What should I do? Ask this at hosting company, or that is some OC bug?

Newbie

Posts

Joined
Sun Oct 25, 2015 5:56 pm

Post by EvolveWebHosting » Sat Jan 30, 2016 1:20 am

Wifialarm wrote:Yes, I can produce the same error and I saw it.

In error list is this:
Image

What should I do? Ask this at hosting company, or that is some OC bug?
It's not a hosting issue and not likely that it's an Opencart bug.

Are you running any mods that effect that part of the website and are all of the files uploaded with the proper CHMOD permissions?

Image
50% Off SSD Shared Hosting w/ cPanel
Detailed guide on how to install Opencart


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by shaftoe » Fri May 20, 2016 4:51 pm

It is indeed a OpenCart 2.2 bug. And it may occur wherever Custom field validation is used . Both front-end and administrator-side.

Whether it actually breaks the page also depends on the server environment. Linux and later php versions seem to be more forgiving.

Newbie

Posts

Joined
Fri May 20, 2016 4:38 pm

Post by straightlight » Sat May 21, 2016 2:49 am

In Opencart 2.2 line 2221 does not exists in admin/controller/sale/order.php file based on the posted error message produced on the error logs above.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 2 guests