Post by WavMixer » Fri Aug 21, 2015 6:41 am

I originally created the site with 1.5.6.4 and have had qphoria upgrade it to 2.0.3.1. I have added the description to the SEO Keyword field and I have set Use SEO URLs to yes. However when I try to access the links to the pages that I have added the SEO keywords to, I get a "not found" error. I have refreshed the modifications page and still get this error. Is there a way to have the SEO URLs work without having to rebuild all of these pages?
Last edited by WavMixer on Sat Aug 22, 2015 1:52 am, edited 1 time in total.

User avatar
New member

Posts

Joined
Sun Feb 23, 2014 3:15 am


Post by deepvision » Fri Aug 21, 2015 10:13 pm

Make sure you have .htaccess file in the root folder with the following content

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

ImageImageImage


User avatar
Active Member

Posts

Joined
Tue May 19, 2015 1:03 am

Post by WavMixer » Sat Aug 22, 2015 1:57 am

That fixed it deepvision!!! Thank you!!!!!

User avatar
New member

Posts

Joined
Sun Feb 23, 2014 3:15 am


Post by zedrally » Wed Sep 02, 2015 10:30 am

That is brilliant, I always wondered why my SEO URL's never worked but it makes me wonder why the code wasn't included in the setup?

Thank you very much.

Active Member

Posts

Joined
Mon Sep 29, 2014 12:12 pm

Post by deepvision » Wed Sep 02, 2015 2:25 pm

zedrally wrote:That is brilliant, I always wondered why my SEO URL's never worked but it makes me wonder why the code wasn't included in the setup?

Thank you very much.
It is actually included but as .htaccess.txt file not as .htaccess file.
In order not to mess up with an existing .htaccess file I guess.

ImageImageImage


User avatar
Active Member

Posts

Joined
Tue May 19, 2015 1:03 am

Post by sunsys » Tue Nov 24, 2015 5:07 pm

@deepvision: I am having a surprising problem in oc-2031, I have SEO enabled in admin and .htaccess file has SEO settings enabled(rewrite engine on) and I have done the changes in database via "url_alias" method but I find that many links for example http://www.mysite.com/index.php?route=product/special is still present whereas I have changed its url_alias in database as query=product/special to keyword="greatoffers" but it does not show as http://www.mysite.com/greatoffers.
Can you suggest some solution please.

Thank you for your time.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by deepvision » Sat Jan 16, 2016 9:16 pm

sunsys wrote:@deepvision: I am having a surprising problem in oc-2031, I have SEO enabled in admin and .htaccess file has SEO settings enabled(rewrite engine on) and I have done the changes in database via "url_alias" method but I find that many links for example http://www.mysite.com/index.php?route=product/special is still present whereas I have changed its url_alias in database as query=product/special to keyword="greatoffers" but it does not show as http://www.mysite.com/greatoffers.
Can you suggest some solution please.

Thank you for your time.
Sorry for the late reply. Have not used the forum much.

Maybe those links are hard coded?

ImageImageImage


User avatar
Active Member

Posts

Joined
Tue May 19, 2015 1:03 am

Post by xaneinc » Tue Apr 12, 2016 9:45 am

@sunsys: If you still have an issue with the links you mentioned, you might find this extension to be the solution.
http://www.opencart.com/index.php?route ... load_id=41
We use this in several stores. Easy to install & works great!

Newbie

Posts

Joined
Mon Sep 21, 2015 3:24 am

Post by sunsys » Mon Apr 18, 2016 7:33 pm

xaneinc wrote:@sunsys: If you still have an issue with the links you mentioned, you might find this extension to be the solution.
http://www.opencart.com/index.php?route ... load_id=41
We use this in several stores. Easy to install & works great!
Thank you for your reply, I am sorry so see that the reviews are not favourable so I will not use the extension till issues are sorted out. I mean just for having friendly urls I cannot afford to have my cart function screwed up.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by Randem » Mon Apr 25, 2016 3:43 am

Hi WavMixer,

Getting SEO URL's & Keywords To Work

Hopefully this can help...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by zee122 » Wed Jun 29, 2016 10:12 pm

I have tried many times it is not working because I did not recognize main folder of opencart. It shows public_html but it is not working kindly help me.

Newbie

Posts

Joined
Wed Jun 29, 2016 10:04 pm
Who is online

Users browsing this forum: No registered users and 3 guests