Page 1 of 1

"NOTIFY CUSTOMER" box in History tab not working

Posted: Fri Jun 19, 2015 5:40 am
by DSTAngieB
When you go to the History tab in a customer's order and change the STATUS of the order, it automatically sends an e-mail notifying the customer even though the "Notify Customer" button is NOT checked!

THIS IS A BUG!!

There are INTERNAL statuses that I have within my company that my customer needs to know nothing about (e.g. when an order moves from pre-production to production or packaging to shipped). It is not always necessary to notify the customer about when their order has moved from one department to the next internally and thus why we always leave the "NOTIFY CUSTOMER" box unchecked. But unfortunately, this 2.0.3) version of OpenCart will send an e-mail to the customer regardless of what you say. BOOOO!

What is the purpose of having a notify customer button if it always is going to default to being ON??

Please fix this in the next release!

Re: "NOTIFY CUSTOMER" box in History tab not working

Posted: Fri Jul 10, 2015 11:05 pm
by GoldenTongs
i thought this was fixed in 2.0.2

Re: "NOTIFY CUSTOMER" box in History tab not working

Posted: Wed Jul 22, 2015 4:27 pm
by TheLizard
Asked 1000 times and never had an official sticky or solution

Re: "NOTIFY CUSTOMER" box in History tab not working

Posted: Thu Sep 17, 2015 4:23 am
by InfiniteDezigns
Well apparently its still not fixed. I get this message when trying to send to the customer:

SyntaxError: JSON Parse error: Unrecognized token '<'
OK
<b>Notice</b>: Undefined offset: 1 in <b>/home/prodsmtw/public_html/sublimation/system/library/Drewm/MailChimp.php</b> on line <b>31</b>{"success":"Success: You have added <a href=\"%s\">%s<\/a> to your <a href=\"%s\">shopping cart<\/a>!"}

Re: "NOTIFY CUSTOMER" box in History tab not working

Posted: Fri Dec 18, 2015 12:24 am
by Troedler
Has this been patched yet?