Post by Ottiko » Fri Apr 10, 2015 6:34 am

At front-side I order product, choose payment method, nice work.

Next, when I see order at admin side, and try to edit and click to Save button, I see alert error "Payment method required!", but Payment method is already choose. Next I try to click "Apply Payment method" button, I see alert "Success: Payment method has been set!" and next when I try to Save, order is already saved "You order has been successfully modified orders"

Why I need to click "Apply Payment method" button if Payment method is already choose? I think its bug...
Screenshot: http://i.imgur.com/hJaY6W1.png

Newbie

Posts

Joined
Fri Apr 10, 2015 6:20 am

Post by Ottiko » Sat Apr 11, 2015 3:44 am

This is my bug, or was it released :'(

Newbie

Posts

Joined
Fri Apr 10, 2015 6:20 am

Post by Ottiko » Sat Apr 18, 2015 3:54 pm

Anybody can help me, or this forum is offline?

Newbie

Posts

Joined
Fri Apr 10, 2015 6:20 am

Post by pm-netti » Sat Apr 18, 2015 4:02 pm

Ottiko wrote:Anybody can help me, or this forum is offline?
http://forum.opencart.com/viewtopic.php ... d!#p534456

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by tbryel » Fri May 01, 2015 4:21 am

Hi otiko,

I have the same problem in OC 2.02, i believe it's a bug that requires solving in the next release.


It's not a major issue as there is a manual workaround: refresh payment method using the button but in an ideal OC application this should not be required.

The solution/link posted discusses a totally different issue, this is not otiko's and everyone else's OC 2 issue.

Kind regards,

Tim

Newbie

Posts

Joined
Tue Apr 28, 2015 9:55 pm

Post by Ottiko » Sun May 24, 2015 7:08 pm

So it is impossible to fix a bug? ???

Newbie

Posts

Joined
Fri Apr 10, 2015 6:20 am

Post by viethemes » Tue May 26, 2015 9:51 pm

You can try to install this OCMOD extension to fix it https://www.dropbox.com/s/960eag90ivrnr ... d.xml?dl=0

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by Ottiko » Thu Jun 04, 2015 8:05 pm

Thx. nice work. ;)

But I add $('#button-shipping-method').trigger('click'); too, because when click Save button, Shipping Method value is delete, but if click Apply Shipping Method and than click Save button it's save nice.

I understand this is quick fix method, but maybe OC developer can to fixed this at new version...
OR
This bugs, I have only?

Newbie

Posts

Joined
Fri Apr 10, 2015 6:20 am

Post by tbryel » Sun Jun 14, 2015 7:27 pm

Hi Ottiko,

No you're not the only one. I would like to have this fixed and my issue where you won't be able to change the tax rate on existing orders as well. But currently they are not yet fixed (release 2.0.3.1). Hopefully they will include a fix in the next release.

We could use a different bug tracker (google I believe) to post our issues, maybe that will help getting these issues under the attention of developers that can implement a fix for the next opencart release.

Kind regards,

Tim

Newbie

Posts

Joined
Tue Apr 28, 2015 9:55 pm

Post by retti » Fri Sep 11, 2015 9:20 pm

I am confirming that this error is persisting with the current 2.0.3.1 version. Any plan to fix this issue in the next release?

Newbie

Posts

Joined
Fri Sep 11, 2015 9:03 pm
Who is online

Users browsing this forum: No registered users and 6 guests