Post by r300 » Wed Oct 11, 2017 6:33 pm

MediaCityWay wrote:
Fri Sep 11, 2015 10:35 pm
I just came across the same problem everyone else seems to be having, here's each step I took to fixing the problem, it may seem like other solutions but follow this step by step. It takes about 2 mins if that.

1. Go to Settings > Users > API
Now delete any and all API users. Once complete add a new API, the username can be anyting you like go for something like STORENAMEApiUser, then click the generate button to give yourself a password then finally make sure status is enabled, once you've done that click save.

2. Just the same as the other solutions go to System > Store > Edit > Option and under checkout make sure the Api user you just created is selected in the API User dropdown box.

3. Now to make it work, go in to your admin config file, mine when I first looked into it looked like this:
define('HTTP_SERVER', 'http://STORENAME.com/admin/');
define('HTTP_CATALOG', 'http://STORENAME.com/');

// HTTPS
define('HTTPS_SERVER', 'http://STORENAME.com/admin/');
define('HTTPS_CATALOG', 'http://STORENAME.com/');

Even though I am currently not using a SSL certifacte change the HTTPS settings to read:

// HTTPS
define('HTTPS_SERVER', 'https://STORENAME.com/admin/');
define('HTTPS_CATALOG', 'https://STORENAME.com/');

Upload the admin config file to its correct location on the server and reload your admin page (or log out and in again) and try updating your order history, works perfectly.
YOU ARE STAR works as a charm.
I run SSL on every single page of my website and the ''s'' in config file fixed all the issue.
Thank you !

Newbie

Posts

Joined
Tue Aug 25, 2015 2:40 am
Who is online

Users browsing this forum: Baidu [Spider] and 11 guests