Post by tyreida » Tue Feb 17, 2015 4:50 am

I met a problem on opencart 2.0.1.1, I can not edit the orders in backend.
Every time the same error:
SyntaxError Unexpected end of input OK


I already did all these things:
1. In Opencart Admin, go to Settings >> API and create a new user.
2. In cPanel navigate to phpMyAdmin and then select your database where your store is installed.
3. Find table oc_setting and then find key "config_api_id".
4. Set the value field to 1 where key = config_ap_id (it was set to 0 on my system).
5. Next go to table oc_api and check that api_id = 1

Problem still not resolve, I found many many solution, but all not work for me.
I think maybe this is a bug for the software.
I hope somebody can help me.

Newbie

Posts

Joined
Tue Feb 17, 2015 4:09 am

Post by viethemes » Tue Feb 17, 2015 5:28 pm

Is your site in maintainence mode? You should turn it off.

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by tyreida » Wed Feb 18, 2015 3:57 am

My shop is not in maintenance mode. I already turn it off.

Newbie

Posts

Joined
Tue Feb 17, 2015 4:09 am

Post by tyreida » Wed Feb 18, 2015 4:13 am

I looked all over the internet and found no answer.

Basically my problem is whenever I try to edit orders and change stores I get the SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data OK in firefox and in chrome I get SyntaxError: Unexpected end of input OK.

Has anyone found a "real" solution for this because I tried all that was suggested but they don't work. From changing the api_id to making a secondary API. And even the .htaccess method.

Newbie

Posts

Joined
Tue Feb 17, 2015 4:09 am

Post by rlasmar » Sat Feb 28, 2015 9:58 am

I have exactly the same problem.

When I try to edit an order in admin panel, I get the following error:

On Google Chrome display:
"SyntaxError Unexpected end of input OK"

On Firefox display:
"SyntaxError: Json.parse: unexpected end of data at line 1 column 1 of the JSON Data OK"

Things that I tried:

A)
1. In Opencart Admin, go to Settings >> API and create a new user.
2. In cPanel navigate to phpMyAdmin and then select your database where your store is installed.
3. Find table oc_setting and then find key "config_api_id".
4. Set the value field to 1 where key = config_ap_id
5. Next go to table oc_api and check that api_id = 1

In my database it was set correctly to "1"

B) My site is NOT in maintenance mode.

C) mod_security is OFF

D) file htaccess is disabled. It named htaccess.txt, as it a new fresh installation of opencart 2.0.1.1

Any other ideas?
Last edited by rlasmar on Thu Mar 12, 2015 7:21 am, edited 2 times in total.

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by JoCoLe » Tue Mar 10, 2015 2:29 am

I'm desperate for an answer to this as well.
I too have tried adjusting maintenance mode, and user group settings, and have even double checked the table data.
Nothing has fixed this.
Please help!

Newbie

Posts

Joined
Tue Mar 10, 2015 2:21 am

Post by bleekk » Thu Mar 12, 2015 5:15 am

I have exactly the same problem. Can someone please help

New member

Posts

Joined
Thu Jan 24, 2008 6:55 am

Post by bleekk » Thu Mar 12, 2015 10:20 pm

I have also talked to my hoster and they are not using mod_security but suhosin.
I have no idea what this is. can this be the problem??

Please help!

Thanks

New member

Posts

Joined
Thu Jan 24, 2008 6:55 am

Post by chilledworld » Fri Mar 13, 2015 2:50 am

I have the same problem, I cannot edit any orders and I cannot change the order status.

Newbie

Posts

Joined
Mon Jan 31, 2011 4:29 am

Post by pm-netti » Fri Mar 13, 2015 6:00 pm

chilledworld wrote:I have the same problem, I cannot edit any orders and I cannot change the order status.
First: Why this is in Bugs thread?

You see in admin setting/setting > edit > tab option > API user.
Is it enabled?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by bleekk » Fri Mar 13, 2015 7:39 pm

I have tried all these things but nothing works

A)
1. In Opencart Admin, go to Settings >> API and create a new user.
2. In cPanel navigate to phpMyAdmin and then select your database where your store is installed.
3. Find table oc_setting and then find key "config_api_id".
4. Set the value field to 1 where key = config_ap_id
5. Next go to table oc_api and check that api_id = 1

In my database it was set correctly to "1"

B) My site is NOT in maintenance mode.

C) mod_security is OFF

D) file htaccess is disabled. It named htaccess.txt, as it a new fresh installation of opencart 2.0.1.1


Mod_security is not enabled but suhosin

New member

Posts

Joined
Thu Jan 24, 2008 6:55 am

Post by pm-netti » Fri Mar 13, 2015 8:31 pm

bleekk wrote:I have tried all these things but nothing works

A)
1. In Opencart Admin, go to Settings >> API and create a new user.
2. In cPanel navigate to phpMyAdmin and then select your database where your store is installed.
3. Find table oc_setting and then find key "config_api_id".
4. Set the value field to 1 where key = config_ap_id
5. Next go to table oc_api and check that api_id = 1

In my database it was set correctly to "1"

B) My site is NOT in maintenance mode.

C) mod_security is OFF

D) file htaccess is disabled. It named htaccess.txt, as it a new fresh installation of opencart 2.0.1.1


Mod_security is not enabled but suhosin
If this is not work (even if all the settings are correct) error is your server. you may ask in web hosting, is it php cURL Library in Use?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by rlasmar » Sat Mar 14, 2015 12:30 am

I have tested all possible solutions in this topic and don't work.

The cURL is activated.

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by bleekk » Sat Mar 14, 2015 1:50 am

On my hoster cURL is also activated

New member

Posts

Joined
Thu Jan 24, 2008 6:55 am

Post by pm-netti » Sat Mar 14, 2015 2:27 am

rlasmar wrote:I have tested all possible solutions in this topic and don't work.

The cURL is activated.
Do you mean that the session 'cookie' is found?

http://forum.opencart.com/viewtopic.php ... pi#p531625

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by gdb » Sun Mar 15, 2015 11:57 pm

I have the same issue..
Can't edit orders can't delete orders and any interaction with orders slows down the site.

gdb
Newbie

Posts

Joined
Sun Mar 15, 2015 11:29 pm

Post by gdb » Tue Mar 17, 2015 9:27 pm


gdb
Newbie

Posts

Joined
Sun Mar 15, 2015 11:29 pm

Post by bleekk » Thu Mar 19, 2015 7:26 pm

Finally I got it!

My PHP Version was 5.3 with "Magic Quotes GPC" ON
This "Magic Quotes GPC" is deprecated since PHP Version 5.4

So I changed the PHP Version to 5.4 and now everything is working fine

New member

Posts

Joined
Thu Jan 24, 2008 6:55 am

Post by OSWorX » Thu Mar 19, 2015 7:49 pm

Quite funny ...

Step 2 of the installer shows everyone the result of the magic_quotes setting.
Red = ON, Green = OFF (should be green!).

What for do you think is this?
Just for fun .. ?

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by bleekk » Thu Mar 19, 2015 9:50 pm

No I do not think that this is for fun.
But the Shop was not developed on the productive server but localy and was transported to the productive server.

Unfortunately the server settings were not same.

New member

Posts

Joined
Thu Jan 24, 2008 6:55 am
Who is online

Users browsing this forum: No registered users and 4 guests