Post by Greg Houston » Sun Feb 08, 2015 2:36 pm

Hi, I am getting the following error when I try to email a newsletter. "E-Mail Message required!"

Any solutions? Thanks.

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Tue Feb 10, 2015 5:37 am

This is on Version 2.0.0.0

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by pm-netti » Tue Feb 10, 2015 8:24 pm

Greg Houston wrote:This is on Version 2.0.0.0
This is bug also in version 2.0.1.1.
Do this change in file system/library/mail.php line 82:

Code: Select all

                         //exit();

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Greg Houston » Wed Feb 11, 2015 1:04 am

Thanks

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Wed Feb 11, 2015 9:35 am

I made the suggested change yet it still didn't send an email.

Of note, Open Cart is sending order confirmation emails fine though I think it may be sending them twice.

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by pm-netti » Wed Feb 11, 2015 8:31 pm

Greg Houston wrote:I made the suggested change yet it still didn't send an email.

Of note, Open Cart is sending order confirmation emails fine though I think it may be sending them twice.
What is file/site, which you are trying to send an email?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Greg Houston » Thu Feb 12, 2015 1:22 am

I might not understand your question. My site is http://fabledaudio.com/

I am trying to send my existing customers a newsletter about a new product and updates I have made to an older product.

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by pm-netti » Thu Feb 12, 2015 2:06 am

Greg Houston wrote:I might not understand your question. My site is http://fabledaudio.com/

I am trying to send my existing customers a newsletter about a new product and updates I have made to an older product.
Ox... I think, what is your form site, (sale/..?), where newsletter sending script is..?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Greg Houston » Thu Feb 12, 2015 2:23 am

This is the page I am on...

/admin/index.php?route=marketing/contact&token=cbadb29490fa5b72a551ca0d3231d7d9

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Thu Feb 12, 2015 2:26 am

I think the file is admin/view/template/marketing/contact.tpl

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Thu Feb 12, 2015 2:32 am

I think it is grabbing the error text from here:

admin/language/english/marketing/contact.php

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by pm-netti » Thu Feb 12, 2015 4:28 am

Greg Houston wrote:I think it is grabbing the error text from here:

admin/language/english/marketing/contact.php
Strange is a error, I test the same.
Javascript form Check to work properly.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Greg Houston » Thu Feb 12, 2015 5:11 am

You get the same error?

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by pm-netti » Thu Feb 12, 2015 5:58 am

Greg Houston wrote:You get the same error?
Yes. I did test offline in status, also did test //exit().
I do not know lähteekö email. But after a while, even though I removed the comment marks, so "exit ()", is no indicated an error, but "text_success" message.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Greg Houston » Thu Feb 12, 2015 3:09 pm

Is anyone able to send out newsletters with OpenCart 2.0?

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by pm-netti » Thu Feb 12, 2015 7:12 pm

Greg Houston wrote:Is anyone able to send out newsletters with OpenCart 2.0?
Hi.
I did test my demo server.
This worked for me as well.
Have you changed somehow your e-mail settings in tab Mail?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Greg Houston » Fri Feb 13, 2015 12:45 am

I haven't changed any settings in that tab. The mail works fine such as notifying me of new customers and sales. It just won't let me send a newsletter.

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Fri Feb 13, 2015 1:54 am

My contact form sends mail correctly as well. There appears to be something wrong with the newsletter specifically.

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Sat Feb 21, 2015 4:07 am

I posted a bug for this on github. https://github.com/opencart/opencart/issues/2693

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am


Post by Greg Houston » Mon Feb 23, 2015 5:36 am

This has been fixed in the repo. I grabbed changes from:

https://github.com/opencart/opencart/bl ... ontact.tpl

and

https://raw.githubusercontent.com/openc ... ontact.php

I'm not sure what the "// Summer not fix" comment means, but that comes right before the fix in contact.tpl.

User avatar
New member

Posts

Joined
Fri Oct 31, 2014 4:40 am

Who is online

Users browsing this forum: No registered users and 7 guests