Post by sat tv guy » Fri Nov 08, 2019 1:52 am

My site is running on Opencart 2.1.0.2, lately when I try to login to the admin panel it just hangs for up to 2 minutes

Seemingly my site is trying to contact 'anythingpro.net' and that is what is causing the 2 minute logins

Has anyone got any ideas what 'anythingpro.net' is and how I can remove it or disbale it ?

Kind Regards
Stephen

Active Member

Posts

Joined
Wed Oct 12, 2011 12:58 am
Location - london

Post by Johnathan » Fri Nov 08, 2019 5:00 am

Not sure what anythingpro.net is for (a Google search says either analytics, or sending/paying money) but it would mean you have a mod that's added that code. Since the site can't be connected to, it's timing out. You should search your vqmods, ocMods, and any other extensions you've installed for what would add that. If you can't find anything, download all your site files and do a search for that domain --- you should be able to find the mod file adding it, and then can remove it.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by sat tv guy » Fri Nov 08, 2019 6:57 pm

Thanks for that suggestion, I did a full website backup which I download and unzipped to a folder on my PC
I then did a SEARCH for anythingpro.net and I got no results ?

So it looks to me like the issue is not with my website but something that is affecting my website, could this be on my Server ?

Kind Regards
Stephen

Active Member

Posts

Joined
Wed Oct 12, 2011 12:58 am
Location - london

Post by sat tv guy » Fri Nov 08, 2019 7:00 pm

The only third party Plugins I have on my site are Paypal Express Plugin and VqMod

Active Member

Posts

Joined
Wed Oct 12, 2011 12:58 am
Location - london

Post by OSWorX » Fri Nov 08, 2019 8:35 pm

Well, it could be also that your web (server) got hacked.

Not by / through OpenCart (nearly impossible if standard and no "stolen" and/or obfuscated /encrypted extensions are installed), but if you have for example also a Wordpress site on the same account (maybe an unpatched / not updated version), everything is possible.
Have seen such also at some providers and if a "shared" server.

Also searching only for that name will lead to zero results.
Because if infected, the hacker has obfuscated the source - therefore you have to look for other string/functions.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Johnathan » Fri Nov 08, 2019 11:19 pm

If you couldn't find anything, ask your web host to do a scan. If your server has been compromised they should help, although you might also consider moving hosts if that's actually the case.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am

Who is online

Users browsing this forum: No registered users and 3 guests