Post by sayyouloveme » Fri Jun 18, 2021 2:57 am

Hello,
index.php?route=extension/payment/webpos/callback page is showing the following errors below after customer completed payment. So customer couldn't pay or paid but not showing in control panel etc....

Notice: Undefined index: webpos_bank_id in /home/xxx/catalog/controller/extension/payment/webpos.php on line 248

Notice: Undefined index: order_id in /home/xxx/catalog/controller/extension/payment/webpos.php on line 250

Notice: Undefined variable: webpos_class in /home/xxx/catalog/controller/extension/payment/webpos.php on line 261

Notice: Undefined offset: 1 in /home/xxx/catalog/controller/extension/payment/webpos.php on line 51

Notice: Error: Could not load webpos helper /home/xxx/system/helper/webpos/adapter/.php! in /home/xxx/catalog/controller/extension/payment/webpos.php on line 57

Webpos payment module installed on Version 2.3.0.2. Was working properly till yesterday. BUt suddenly thess errrors occured
Have you any idea?

Newbie

Posts

Joined
Wed Mar 08, 2017 9:47 pm

Post by ADD Creative » Fri Jun 18, 2021 5:27 am

Have you made any changes to your site at all? Have you asked your host if they have made any changes to your hosting?

Could also be a SameSite cookie issue. Check your web browser's developer console for any warnings.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by straightlight » Fri Jun 18, 2021 6:52 am

Contact the extension developer to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by paulfeakins » Fri Jun 18, 2021 7:28 pm

The host probably updated the PHP version but you should contact the extension developer.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by straightlight » Fri Jun 18, 2021 7:30 pm

Redundancy.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by sayyouloveme » Sun Jun 20, 2021 8:26 pm

Many thanks to all replies. I have checked SameSite cookie issue and done updates myself. It worked now. (developer lost so i asked here)
The error was telling nothing. That was chrome browser issue only. Firefox was OK
Thank you all very much.

Newbie

Posts

Joined
Wed Mar 08, 2017 9:47 pm
Who is online

Users browsing this forum: No registered users and 33 guests