Post by Jeens » Sat Jul 11, 2020 5:25 pm

I would like to upgrade php from 7.0.33 to 7.4.6.

Is it save to do so?
Is opencart 2.3.0.2 even compatible with php 7.4.6?
I know some modules might stop working. It happened when we upgraded from 5.6 to 7.

I can change the php version myself in the hoster's webpanel so it is possible to revert easily if things go wrong, the question is though, if such a change (from 7 to 7.4 and back to 7 in case of failure) would break anything?
Or is it save to change the php version as often as I like?

The second question is:
Do you have to manually remove cache files, or other files when changing the php version or maybe do something else with the opencart installation?

Thanks!

Newbie

Posts

Joined
Sat Jul 11, 2020 5:16 pm

Post by IP_CAM » Sat Jul 11, 2020 11:26 pm

You might have to replace the content of the system/library/encryption.php File
with the Content shown in the Page linked, to make 2.x Versions work with PHP 7.4.x.
Ernie
viewtopic.php?f=20&t=218940#p793149

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.jacob.ch/shop/
My Github OC Site: https://github.com/IP-CAM
2'450+ FREE OC Extensions from the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Jeens » Sun Jul 12, 2020 4:33 pm

Thank you a lot!

The creators of one of our essential modules said their module won't run with 7.4, only 7.2.
Now my question is, Opencart 2.3.0.2 is able to run on php 7.2.?

Newbie

Posts

Joined
Sat Jul 11, 2020 5:16 pm

Post by OSWorX » Sun Jul 12, 2020 5:20 pm

Jeens wrote:
Sun Jul 12, 2020 4:33 pm
Now my question is, Opencart 2.3.0.2 is able to run on php 7.2.?
Yes.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by paulfeakins » Mon Jul 13, 2020 6:15 pm

Jeens wrote:
Sat Jul 11, 2020 5:25 pm
I can change the php version myself in the hoster's webpanel so it is possible to revert easily if things go wrong, the question is though, if such a change (from 7 to 7.4 and back to 7 in case of failure) would break anything?
You should be able to switch it and then switch back easily without breaking anything BUT ALWAYS have a backup just in case.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 37 guests