Post by julianashcroft » Sat Jul 04, 2020 5:20 pm

Last night I got a confirmation email of an order followed by a paypal email to say the order had been paid. When I checked the order in Opencart, the product and the amount were different to what came through on the email.

The email seems to be correct as the customer added some personalisation which shows up in the email and the paypal payment matches that in the email.

Never had this before, anyone got any ideas?

New member

Posts

Joined
Mon Feb 23, 2015 12:24 am

Post by rjcalifornia » Sun Jul 05, 2020 11:38 am

julianashcroft wrote:
Sat Jul 04, 2020 5:20 pm
Last night I got a confirmation email of an order followed by a paypal email to say the order had been paid. When I checked the order in Opencart, the product and the amount were different to what came through on the email.

The email seems to be correct as the customer added some personalisation which shows up in the email and the paypal payment matches that in the email.

Never had this before, anyone got any ideas?
How much was the difference?

Seen this issue might be related with Journal theme and using the one-page checkout. What is your OpenCart version? Which checkout modules are you using?

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by julianashcroft » Sun Jul 05, 2020 4:28 pm

Thanks for the reply.
The order in opencart was a totally different product and different price to that confirmed in the email.
I'm using Opencart 2.0.1.1 and am using the Journal 2.16.8 theme with the quick checkout.
It gets a little stranger, the same customer decided the next day to order the same product again, but with different personalisation. I was in email contact with him by now and he said opencart wouldn't let him pay as it said payment had already been paid, in Opencarts backend, this new order had now replaced the previous wrong order.
I received another order from a different customer a little later in the day without any issues, hopefully just a glitch. I have cleared the Journal Cache, so hoped that helped.

New member

Posts

Joined
Mon Feb 23, 2015 12:24 am

Post by paulfeakins » Mon Jul 06, 2020 6:16 pm

julianashcroft wrote:
Sun Jul 05, 2020 4:28 pm
I'm using Opencart 2.0.1.1 and am using the Journal 2.16.8 theme with the quick checkout.
Contact Journal.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by rjcalifornia » Mon Jul 06, 2020 8:38 pm

julianashcroft wrote:
Sun Jul 05, 2020 4:28 pm
Thanks for the reply.
The order in opencart was a totally different product and different price to that confirmed in the email.
I'm using Opencart 2.0.1.1 and am using the Journal 2.16.8 theme with the quick checkout.
It gets a little stranger, the same customer decided the next day to order the same product again, but with different personalisation. I was in email contact with him by now and he said opencart wouldn't let him pay as it said payment had already been paid, in Opencarts backend, this new order had now replaced the previous wrong order.
I received another order from a different customer a little later in the day without any issues, hopefully just a glitch. I have cleared the Journal Cache, so hoped that helped.
Contact Journal developer, Just for reference:

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by icestudios » Wed Jul 08, 2020 7:36 pm

Hi,
I've been having a similar issue recently and also using Journal Quick Checkout & OC 2.3.0.2 - three that I'm aware of.

An order comes in and I receive an order confirmation email showing the order. When I check the admin area, the order has changed and the products are not the same as shown in the order confirmation email. Same order id, but different products! On speaking with the customer, they placed the initial order, which I received the order confirmation for, then shortly afterwards, they decided to order something else. When they returned to the store, their initial order items were still in the cart, so they deleted them and added different items and placed the order. It is those items that are shown in the admin area with the same order id. However, no order confirmation email was received for the second order. In this case they did order twice and paid twice.

However, the latest occurrence of the problem was even stranger. I received an order confirmation email and when I checked the admin area, the products ordered were different to the order confirmation. On speaking with the customer, they placed an order for a product and paid. They then went back to the store and put some other products in the basket and went to checkout, but did not complete the checkout as they were called away. In this case, it was these products that were shown in the admin area, but the order wasn't completed or paid for!!!

Only been aware of this problem recently and have yet to contact Journal, but will do so shortly.

Would appreciate to hear anyone else's outcome.

Newbie

Posts

Joined
Fri Feb 15, 2013 6:14 am

Post by IP_CAM » Wed Jul 08, 2020 7:49 pm

icestudios wrote:
Wed Jul 08, 2020 7:36 pm
Only been aware of this problem recently and have yet to contact Journal, but will do so shortly.
Well, what's keeping you from doing it ? It's not an OC -related Problem, as it looks ... :D

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.jacob.ch/shop/
My Github OC Site: https://github.com/IP-CAM
2'450+ FREE OC Extensions from the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by icestudios » Wed Jul 08, 2020 8:05 pm

..... as mentioned, just noticed it recently and only saw related post today as I was looking for a solution. Will contact Journal today, once I renew support license. I'll update here with their response.

Newbie

Posts

Joined
Fri Feb 15, 2013 6:14 am
Who is online

Users browsing this forum: No registered users and 32 guests