Post by orik3ll0 » Mon Feb 18, 2019 6:42 am

Hi to all :)

OC: 2.3.0.2

I am trying to configure online patment service on my website. All functions are working and i am able to redirect to payment page. After filling inputes with my credit card info on submit I have added my page which will show on succeed.
For me it is:
https://mysite/index.php?route=extensio ... 507480ebba

As you can see i am redirecting it to callback function, but because of GET data '?payment_key=52e3ea06-cd1b-49e6-85c1-12507480ebba' it can not enter to function( shows me 404 page not found) and i am not able to get GET['payment_key'].

P.S. it works on '&payment_key=52e9ea06-ed1b-49e6-81c1-12507480ebba' but not working on '?payment_key=52e9ea06-ed1b-49e6-81c1-12507480ebba'
Stucked 2-3 days. Please help me to find right way to do it.

Thank you for attention and help.
Last edited by orik3ll0 on Mon Feb 18, 2019 6:47 am, edited 1 time in total.

Newbie

Posts

Joined
Sat Apr 14, 2018 6:37 am

Post by straightlight » Mon Feb 18, 2019 6:45 am

shows me 404 page not found
No OC version posted. However, to which URL is it showing a 404 error message in your logs? Secondly. from your merchant account on your provider's web site, ensure to route the callback URL with your original callback URL.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by orik3ll0 » Mon Feb 18, 2019 2:33 pm

orik3ll0 wrote:
Mon Feb 18, 2019 6:42 am
Hi to all :)

OC: 2.3.0.2

I am trying to configure online patment service on my website. All functions are working and i am able to redirect to payment page. After filling inputes with my credit card info on submit I have added my page which will show on succeed.
For me it is:
https://mysite/index.php?route=extensio ... 507480ebba

As you can see i am redirecting it to callback function, but because of GET data '?payment_key=52e3ea06-cd1b-49e6-85c1-12507480ebba' it can not enter to function( shows me 404 page not found) and i am not able to get GET['payment_key'].

P.S. it works on '&payment_key=52e9ea06-ed1b-49e6-81c1-12507480ebba' but not working on '?payment_key=52e9ea06-ed1b-49e6-81c1-12507480ebba'
Stucked 2-3 days. Please help me to find right way to do it.

Thank you for attention and help.
I found my mistakes,
1) I forgot to add " &" to my succed page link at the end
2) i can get GET data not as `$this->request->get['payment_key'];`, should get it as `$this->request->get['?payment_key'];` with "?"

Newbie

Posts

Joined
Sat Apr 14, 2018 6:37 am

Post by straightlight » Mon Feb 18, 2019 9:47 pm

Glad you got it working. However, using the ? in the query key is not very common. You could parse your query keys with these examples: https://stackoverflow.com/questions/539 ... o-an-array

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by orik3ll0 » Wed Feb 20, 2019 4:32 am

straightlight wrote:
Mon Feb 18, 2019 9:47 pm
Glad you got it working. However, using the ? in the query key is not very common. You could parse your query keys with these examples: https://stackoverflow.com/questions/539 ... o-an-array
Thank you for this example, i used it in my code also)

Newbie

Posts

Joined
Sat Apr 14, 2018 6:37 am
Who is online

Users browsing this forum: No registered users and 5 guests