Page 1 of 1

Help with theme problem

Posted: Sat Oct 13, 2018 12:17 pm
by zedrally
OC 2.0.3.1
The theme dev. has gone off air and there are several users who are stranded with a non working theme.
I'm attempting to unravel what went wrong and am looking for help, it's possible that this could be a subtle change in the dDBbut then again who am I to guess.

The error logs shows:
2018-10-13 15:04:16 - PHP Notice: unserialize(): Error at offset 34 of 39 bytes in /home/blackcat/public_html/system/library/vie_front.php on line 36

The code is:

Code: Select all

	$this->skin_options[$row['option']] = unserialize($row['value']);
What I don't know is what the error log is trying to tell me, has anyone got a wild guess?
FWIW this extension has been flawless for 3 years and only has started playing up for most users in the past 3 months.

TIA

Re: Help with theme problem

Posted: Sat Oct 13, 2018 7:15 pm
by cyclops12
zedrally wrote:
Sat Oct 13, 2018 12:17 pm
OC 2.0.3.1
it's possible that this could be a subtle change in the dD
What could you have changed in the DB then ?

Re: Help with theme problem

Posted: Sat Oct 13, 2018 7:47 pm
by xxvirusxx

Re: Help with theme problem

Posted: Sun Oct 14, 2018 4:49 am
by zedrally
Thanks, unfortunately that hasn't solved the problem and has introduced another error.

Code: Select all

2018-10-14 7:42:40 - PHP Notice:  unserialize(): Error at offset 34 of 39 bytes in /home/blackcat/public_html/system/library/vie_front.php on line 38
2018-10-14 7:42:46 - PHP Notice:  unserialize(): Error at offset 34 of 39 bytes in /home/blackcat/public_html/system/library/vie_front.php on line 38
2018-10-14 7:43:06 - PHP Notice:  unserialize(): Error at offset 34 of 39 bytes in /home/blackcat/public_html/system/library/vie_front.php on line 38
2018-10-14 7:43:27 - PHP Notice:  unserialize(): Error at offset 34 of 39 bytes in /home/blackcat/public_html/admin/model/vie/theme_editor.php on line 298
2018-10-14 7:43:29 - PHP Notice:  unserialize(): Error at offset 34 of 39 bytes in /home/blackcat/public_html/admin/model/vie/theme_editor.php on line 298
201

Re: Help with theme problem

Posted: Sun Oct 14, 2018 4:53 am
by IP_CAM
Well, the DEV of the Mod, related to this, still seems to be alive and well! :D
http://www.viethemes.com/downloads/cate ... me-editor/

Re: Help with theme problem

Posted: Mon Oct 15, 2018 5:09 am
by zedrally
Thanks ernie, problem is that he is not responding to emails.

Re: Help with theme problem

Posted: Mon Oct 15, 2018 5:18 am
by IP_CAM
Well, you could try to contact him here:
http://www.viethemes.com/contact/
But since your Posting shows a lot of serialized-related Errors,
wich is no longer 'standard' in later OC-Versions, as I believe to have
been reading about, you might just use the wrong OC Version, or the
wrong Extension for your Version.
Ernie

Re: Help with theme problem

Posted: Mon Oct 15, 2018 7:08 am
by zedrally
THanks ernie, I have tried every email address and contact form I can find but he has gone AWOL.
I have used this extension for nearly 3 years and there has been no problem with it on this site, it is in use on another site of mine and works as it should.
I have replaced the file with a copy of the working version and still no luck, so I'm not sure what unserialise should be doing and is not?

Re: Help with theme problem

Posted: Mon Oct 15, 2018 7:22 am
by IP_CAM
There must be a difference between those two Servers, either the PHP Version
used, or then some difference in the Code and/or Mods. I can't think about
anything else. But he may be on vacation, so, just hold on and wait a while ... ;)
But I can't help with that serialize, it's beyond my technical knowledge on such.
Ernie

Re: Help with theme problem

Posted: Mon Oct 15, 2018 7:48 am
by zedrally
The working one is using php 5.6, whilst the other is and has been on php7.2 since early this year. Changing versions has no effect.
I have added a import/export module since then, I had thought that could have caused this, although disabled now I will look into removing it.

Re: Help with theme problem

Posted: Mon Oct 15, 2018 10:20 am
by IP_CAM
Well, different PHP Versions might have a profound effect on such, but you would have
to clean out all of your cached File Content first, in any case, before re-testing something.
Just to have this mentioned too !
Ernie