Post by FrogMan » Mon Sep 17, 2018 5:39 pm

Greetings,

Orders to my store have really slowed down lately. And many of the one's I'm getting are "Pending" and never finish payment to Paypal. Or multiple orders same orders in a row that are not paid/finished. Does anyone know what might be happening?

1 customer said : "i hit submit button but nothing happens so i try again but nothing happens"

New member

Posts

Joined
Thu Jun 08, 2017 12:38 am

Post by straightlight » Mon Sep 17, 2018 9:05 pm

No OC version posted.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by FrogMan » Mon Sep 17, 2018 9:14 pm

Sry... Version 2.3.0.2

New member

Posts

Joined
Thu Jun 08, 2017 12:38 am

Post by straightlight » Mon Sep 17, 2018 9:40 pm

From the developers kit - > console tab, what do you see when hitting the submit button? Also, which payment module are you using? More information is needed. Error / Server access logs required.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by thekrotek » Mon Sep 17, 2018 9:48 pm

If "nothing happens" means that customer stays on the same page, you have JavaScript error then. You can debug it using Developer Tools of your browser. Basic coding/debugging skills are required.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by straightlight » Mon Sep 17, 2018 9:52 pm

Redundancy.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by thekrotek » Mon Sep 17, 2018 10:24 pm

straightlight wrote:
Mon Sep 17, 2018 9:52 pm
Redundancy.
Be so kind to watch what you post. Half of your posts are redundant and provide zero help, just increase post counter.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by straightlight » Tue Sep 18, 2018 12:24 am

As of yours. I have posted the answer already on the above and you posted the same solution right underneath it. Read before you post despite of the quality of response that one may believe.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by FrogMan » Tue Sep 18, 2018 2:19 am

error log attached.

most of my orders are now coming in as "pending". and this has never happened before

thank you
Last edited by FrogMan on Tue Sep 18, 2018 5:47 am, edited 1 time in total.

New member

Posts

Joined
Thu Jun 08, 2017 12:38 am

Post by straightlight » Tue Sep 18, 2018 2:32 am

The verify_sign 's string lines should not be posted on the public forum for security purposes. However, the rest of the information regarding the undefined offset messages are fine to post publicly excluding the customer's confidential information in accordance of PCI. Since you are using Authorize.net AIM (and unmentioned on your first post) , this error may be caused by possible changes through their API.

In catalog/controller/extension/payment/authorizenet_aim.php file,

find:

Code: Select all

$results = explode('|', $response);
add below:

Code: Select all

$this->log->write('AUTHORIZENET_AIM :: DEBUG :: ' . json_encode($results));
Then, clear your logs in the OC admin and test a new transaction. Post the results outputted from the OC admin logs (without posting the verify_sign 's real string this time (replace with Xs).

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by FrogMan » Tue Sep 18, 2018 6:45 am

there does not seem to be this line in that file
$results = explode('|', $response);

New member

Posts

Joined
Thu Jun 08, 2017 12:38 am

Post by straightlight » Tue Sep 18, 2018 9:52 am

This line should be there. If it isn't, ensure from the downloaded ZIP file of OC v2.3.0.2 release from opencart.com that this line is indeed indicated.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by FrogMan » Wed Sep 19, 2018 2:29 am

I can't find that line. I sent you the file via Pm.

Maybe someone can help me.

My orders are still coming in as pending. (payment via paypal is not finishing)

New member

Posts

Joined
Thu Jun 08, 2017 12:38 am

Post by straightlight » Wed Sep 19, 2018 5:31 am

Provided attached file over PM regarding the line does exist on file and confirmed it to the user.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by FrogMan » Wed Sep 19, 2018 6:13 am

Thank you for your timely reply.

I just realized the problem.

I DO NOT have Authorize.net enabled but it is still listed in my payment options (i only have ever used Paypal):

"Please select the preferred payment method to use on this order.
Credit Card / Debit Card (Authorize.Net)
PayPal "

New member

Posts

Joined
Thu Jun 08, 2017 12:38 am
Who is online

Users browsing this forum: No registered users and 40 guests