Page 1 of 1

#Solved# Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 12:36 am
by kec
Hi,

After moving a shop from a subdir to the maindir all things went fine. After all things looked good I installed a new Payment mod (Mollie). After setup I got the error in the checkout that there was no payment option available. I called Mollie and over there all things were cool. For myself; i installed this mod dozens of times without any problems.

What I did was: refreshed numerous times, delete cache from store and browser and reinstalled it. Same error.
So what I did was check the error.log and this came out:

Code: Select all

Fatal error:  Uncaught Exception: Error: Could not load model payment! in /var/www/vhosts/domain.nl/httpdocs/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php:169
Stack trace:
#0 /var/www/vhosts/domain.nl/httpdocs/system/engine/proxy.php(25): Loader->{closure}(Array, Array)
#1 /var/www/vhosts/domain.nl/httpdocs/catalog/controller/checkout/payment_method.php(53): Proxy->__call('getMethod', Array)
#2 /var/www/vhosts/domain.nl/httpdocs/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(51): ControllerCheckoutPaymentMethod->index()
#3 /var/www/vhosts/domain.nl/httpdocs/catalog/controller/startup/router.php(25): Action->execute(Object(Registry))
#4 /var/www/vhosts/domain.nl/httpdocs/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(51): ControllerStartupRouter->index()
#5 /var/www/vhosts/domain.nl/httpdocs/system/engine/front.php(34): Action->execute(Object(Registry))
#6 /var/www/vhosts/doma...
', referer: https://www.domain.nl/betaling
What could cause this error?

Shop: Standard OC 2.3.0.2 with several mods installed.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 1:39 am
by straightlight
See this post: http://forum.opencart.com/viewtopic.php?f=183&t=165958

You are using an upgraded version of Opencart which your extension folders are still being loaded as the old way it used to be loaded with OC as they need to be moved by following the topic's instructions.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 4:57 pm
by kec
Hi,

Thank you for your response and I hoped it was the solution but it's not. All files were already on the right position. So it has another cause.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 6:03 pm
by straightlight
Then more information would need to be posted. Any extensions installed? Clearly, from the first post, VQCache files are being used. So far, these error messages are caused by an installed extension.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 6:25 pm
by kec
Thank you for your time and answer.
The install is an ocmod install and uses no vqmod files? On other OC shops with the same version the same mod works well. So, like you said, I guess there is some kind of conflict. But I have not the slightest clue where to look.

If you want I can give you login credentials. And, if needed, financial payment.

Fyi: the mod is on this page: https://github.com/mollie/OpenCart/releases

V 8.2.3
Filename: mollie-opencart-2.3-and-up.ocmod.zip

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 6:29 pm
by straightlight
To analyze conflicts, use the VQMod Manager from the Marketplace. Even though you may have installed an OCMod extension rather than VQMod but that you are still using VQMod still may cause a conflict for one-to-many reasons.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 7:16 pm
by kec
Hi,

The error log from the VQMod Manager is empty when doing a payment. Still get the message that there is no payment option.

Update: Disabled all the vqmod scripts one by one. Still same error and no error log.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 7:20 pm
by straightlight
Then the issue lies with the extension you have installed or you did not configured your geo zone settings in your store.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 7:24 pm
by kec
Yes, they are setup correctly. See att.

Question: which dir is responsible in OC for entering the payment files?

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 7:26 pm
by straightlight
If the geo zones are properly configured, then the remaining issue would be with the installed extension. Contact the extension developer to resolve this issue.

Re: Fatal error: Could not load model payment!

Posted: Thu Mar 29, 2018 8:35 pm
by kec
And after your last answer I decided to upload an old version of Mollie V 7.2.0 for OC 2.3.0.2. And guess what... It worked.
I will contact Mollie Payment right away that there are serious flaws in their api's.

Again, thank you for your time, effort and help which is highly appeciated.

Kind regards,

Kec