Post by guidone » Sun Mar 25, 2018 5:38 pm

Hi,

if i enable Gzip compression in settings , all admin pages crash and i need to set to 0 via phpmyadmin to work again.
Please see this clip: http://recordit.co/StNR6ARxoX

Image
Please help me on this!

Thanx

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by straightlight » Sun Mar 25, 2018 9:32 pm

No complete OC version posted, video clip is not in English.

However, in your php.ini file, ensure this line is added:

Code: Select all

zlib.output_compression = On
or:

Code: Select all

extension=zlib.so
zlib.output_compression = On
If both solutions remains unchanged as per the result of your site, see these instructions: https://forum.ivorde.com/php-fatal-erro ... 19726.html . Although, if don't feel confident on adding GZIP library yourself, contact your host so they can do it.

I would also encourage to check your access logs regarding these activities in order to clarify the source of the problem.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by guidone » Sun Mar 25, 2018 9:54 pm

Thanx for your replay.
The version is Opencart 2.2.0.0
I need to clarify that problem is about /admin only not frontpage.
Browser error: ERR_CONTENT_DECODING_FAILED

Please help if you have an idea on how to fix this.
Thanx

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by straightlight » Sun Mar 25, 2018 9:59 pm


The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by guidone » Sun Mar 25, 2018 11:21 pm

This problem don't happen in 2.3 version, only on 2.2.
How can i find the difference between old and new code?

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by straightlight » Sun Mar 25, 2018 11:22 pm

You can try by replacing the system/library/response.php file.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by guidone » Mon Mar 26, 2018 12:12 am

Hi,

i hoped you found the problem because it must be one of the files in /system but unfortunately it seems it's not respose.php or not only ...
please help again if you cam, i'm going crazy since first OC 2.2 installation 3 years ago!
Thanx

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by straightlight » Mon Mar 26, 2018 12:15 am

Which PHP version are you using?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by guidone » Mon Mar 26, 2018 1:15 am

PHP Version 5.4.45
Image

Image
Last edited by guidone on Mon Mar 26, 2018 1:20 am, edited 1 time in total.

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by straightlight » Mon Mar 26, 2018 1:18 am

PHP v5.6 minimum is recommended to use Opencart but preferable with PHP v7.1+ . You can also try to add this line in your php.ini file:

Code: Select all

zlib.output_compression = On
but without guarantee of success without upgrading PHP.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by guidone » Mon Mar 26, 2018 1:22 am

It's strange because on same server i have both version, OC 2.2 has problem with Gzip and OC 2.3 it works.

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by straightlight » Mon Mar 26, 2018 1:25 am

Upgrading your OC version would be one way to go.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Mon Mar 26, 2018 8:56 am

Well, and this information would not do much good, since OpenX seemengly does not support mysqli.
Ernie
---
https://stackoverflow.com/questions/140 ... ing-failed
OpenX requires the following PHP extensions:
Either the mysql extension, or the pgsql. The mysqli extension is not supported. The ZLib extension, to convert links inside compressed Flash files generated by Flash MX. The FTP extension. If this is not present OpenX will try to simulate it, which can be a less stable solution.
---

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'100+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by guidone » Mon Mar 26, 2018 2:52 pm

Hi,

after more then 3 years i found out the problem, it was an error in my italian language file, if i switch to English for admin it's all ok!

Thanx for support.

User avatar
New member

Posts

Joined
Thu Mar 28, 2013 7:39 pm

Post by FabTop » Wed Sep 19, 2018 10:28 am

guidone wrote:
Mon Mar 26, 2018 2:52 pm
Hi,

after more then 3 years i found out the problem, it was an error in my italian language file, if i switch to English for admin it's all ok!

Thanx for support.
Grazie Guidone!
I already knew this issue.
My OC version 2.2 with italian language, same situation.

Tonight i tried to speed up my website knowing back office would be hanged. After compression setting to 4, browser reported 303 error on admin side. According to your suggestion i changed admin language to en-gb in oc_setting table and it's ok!
It's a patch, but it works.

I'll try to solve the issue on italian language version. ;)

Newbie

Posts

Joined
Tue Jan 31, 2017 10:33 pm
Who is online

Users browsing this forum: No registered users and 5 guests