Post by Rainforest » Thu Jan 11, 2018 8:14 pm

I've looked at few forum posts but can't really pinpoint what the problem is.

I'm getting almost daily emails from Paypal on both my OC 2.3.0.2 stores about :

Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing

The URL I have is
https://www.mysite.com/index.php?route= ... t/callback

I understand the above URL doesn't actually lead anywhere and that the OC Paypal Standard module actually takes care of the callback. However, I still get the message that the URL are failing.

In IPN history, I see a lot of "retry and then sent" for a few messages
So it seems to be working but it has to try the message once or twice.
Image

Any ideas?
If I turn of IPN messages, I think my orders go to "missing" status.
Last edited by Rainforest on Wed Jan 17, 2018 7:54 pm, edited 1 time in total.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by paulfeakins » Thu Jan 11, 2018 9:08 pm


For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by Rainforest » Wed Jan 17, 2018 2:45 am

No luck.
I did notice though that the your post suggests:

index.php?route=payment/pp_standard/callback

we had a slightly different one:

index.php?route=payment/paypal_direct/callback

I changed it but I'm not sure if that will make a difference as either URL leads to a 404 since it's not a real page. It's my understanding you could put anything there but the module itself sets the callback url? Right?


Also, if anyone does virtual terminal payments or sends a payment link it will create this IPN error message
Last edited by Rainforest on Wed Jan 17, 2018 3:09 am, edited 3 times in total.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by Rainforest » Wed Jan 17, 2018 2:55 am

Also, when looking at the IPN history...the messages that are "successfull" seem to have a different url than the one you suggest or the one I had.

The url is a
index.php?route=extension/payment/pp_standard/callback

I changed it to that to see if it fixed the problem.

So far a test order came out successful.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by Rainforest » Wed Jan 17, 2018 7:56 pm

So, if anyone has this problem. Here is how I solved it:

1. Went into PayPal and into IPN History
2. Looked to see which IPN messages were successful and which were not.
3. Took the URL of the successful messages and put that as my callback URL (which happens to be totally different than the ones suggested by opencart)
4. Problem solved.

Image

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am
Who is online

Users browsing this forum: No registered users and 11 guests