Post by sijones » Mon Dec 04, 2017 4:40 am

Hi,
V2.3.0.2

I've been trying to get the list by manufacturer working, am not sure when it broke but it has and am trying to work out where i need to look.
website is www.hawkonline.uk

Example https://www.hawkonline.uk/ancient-wisdom doesn't list the product by this manufacturer, SEO works on products and categories fine elsewhere, and without SEO https://www.hawkonline.uk/index.php?rou ... urer_id=11 doesn't work either.

So what do I need to look for to try find where the problem could be?

Thanks in advance for any help/hints.

Newbie

Posts

Joined
Mon Jan 30, 2017 7:04 am


Post by straightlight » Wed Dec 06, 2017 11:12 pm

SEO extension issues or .htaccess configuration issues. If installed from the core, I would suggest to look on the marketplace for the many provided solutions in order to rectify this issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by sijones » Thu Dec 14, 2017 1:19 am

Thanks for the reply, apologies for delay in coming back, i thought the forum might send emails to say a reply has happen but it doesnt! My bad.

I put the rewrite rules in the apache conf for better performance - would this cause issues? - the rules are below.

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/uksb_sitemaps/all&store=0 [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|svg|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

Options +FollowSymLinks -Indexes
AllowOverride None

Newbie

Posts

Joined
Mon Jan 30, 2017 7:04 am


Post by IP_CAM » Thu Dec 14, 2017 8:46 am

i thought the forum might send emails to say a reply has happen but it doesnt!

Sure it does, but this function needs to be activated.
Ernie
---
Image

Attachments

notification-setting_oc.jpg

notification-setting_oc.jpg (69.43 KiB) Viewed 501 times


For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by sijones » Mon Dec 18, 2017 4:57 am

As a test i disabled SEO, changed the config for Apache back to normal etc so SEO wasn't involved. It still did the same thing so it's something in a file that's been changed I guess, just got to find which one!

Newbie

Posts

Joined
Mon Jan 30, 2017 7:04 am


Post by straightlight » Mon Dec 18, 2017 5:01 am

sijones wrote:
Mon Dec 18, 2017 4:57 am
As a test i disabled SEO, changed the config for Apache back to normal etc so SEO wasn't involved. It still did the same thing so it's something in a file that's been changed I guess, just got to find which one!
After you revert the settings on Apache, what are the most recent access log entries indicates since regarding the navigation?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by sijones » Mon Dec 18, 2017 5:52 am

Ok, so I didn't look at the access logs, but have just redone the test to get them.

81.138.232.210 - - [17/Dec/2017:21:48:49 +0000] "GET /index.php?route=product/manufacturer/info&manufacturer_id=11 HTTP/1.1" 200 13172
81.138.232.210 - - [17/Dec/2017:21:48:23 +0000] "GET /index.php?route=product/manufacturer/info&manufacturer_id=44 HTTP/1.1" 200 13172

Is that what you wanted?

Newbie

Posts

Joined
Mon Jan 30, 2017 7:04 am


Post by sijones » Mon Dec 18, 2017 6:07 am

After a little bit of digging I've found errors in apache log and in opencart error log, so it seems like a theme problem?

[Sun Dec 17 14:02:00.262707 2017] [:error] [pid 3284] [client 66.249.93.84:53999]
PHP Fatal error: Uncaught Error: Call to a member function getModule() on null in /var/www/html/opencart/catalog/controller/common/headerbottom.php:58\n
Stack trace:\n#0 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(58): ControllerCommonHeaderBottom->index(Array)
\n#1 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php(24): Action->execute(Object(Registry), Array)\n
#2 /var/www/html/opencart/vqmod/vqcache/vq2-catalog_controller_common_header.php(127): Loader->controller('common/headerbo...')\n
#3 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(58): ControllerCommonHeader->index(Array)\n
#4 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php(24): Action->execute(Object(Registry), Array)\n
#5 /var/www/html/opencart/catalog/controller/product/manufacturer.php(409): Loader->controller('common/header')\n
#6 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modifica in /var/www/html/opencart/catalog/controller/common/headerbottom.php on line 58
[Sun Dec 17 19:37:22.605835 2017] [:error] [pid 11915] [client 66.249.66.84:61972]
PHP Fatal error: Uncaught Error: Call to a member function getCategory() on null in /var/www/html/opencart/vqmod/vqcache/vq2-catalog_controller_common_header.php:120\n
Stack trace:\n
#0 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(58): ControllerCommonHeader->index(Array)\n
#1 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php(24): Action->execute(Object(Registry), Array)\n
#2 /var/www/html/opencart/catalog/controller/error/not_found.php(49): Loader->controller('common/header')\n
#3 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(58): ControllerErrorNotFound->index()\n
#4 /var/www/html/opencart/catalog/controller/startup/router.php(25): Action->execute(Object(Registry))\n
#5 /var/www/html/opencart/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(58): ControllerStartupRouter->index()\n
#6 /var/www/html/opencart/system/storage/modification/system/engine/front.php(47): Action->execute(Ob in /var/www/html/opencart/vqmod/vqcache/vq2-catalog_controller_common_header.php on line 120

2017-12-17 20:55:33 - PHP Notice: Undefined variable: categories_info in /var/www/html/opencart/vqmod/vqcache/vq2-catalog_controller_common_header.php on line 121

2017-12-17 17:01:53 - PHP Notice: Undefined property: Template\PHP::$request in /var/www/html/opencart/vqmod/vqcache/vq2-catalog_view_theme_oc02_template_common_header.tpl on line 129
2017-12-17 17:01:53 - PHP Notice: Trying to get property of non-object in /var/www/html/opencart/vqmod/vqcache/vq2-catalog_view_theme_oc02_template_common_header.tpl on line 129

Newbie

Posts

Joined
Mon Jan 30, 2017 7:04 am


Post by straightlight » Mon Dec 18, 2017 6:17 am

Your assumption is correct. It is an issue with a custom theme: oc02. Revert back to the default theme and see if the reported problem can be replicated. If not, contact the theme developer from where you originally downloaded the oc02 theme to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Mon Dec 18, 2017 6:36 am

In addition, take note that the system/storage folder must be located outside of your public_html folder. Then, to edit your config.php and admin/config.php files to adjust the new storage path accordingly. Then, to clear your cache after logging out of your Opencart admin session. Take note that the above error messages also shows the modification folder which means being caused by an installed extension and not only by the custom theme.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by sijones » Mon Dec 18, 2017 6:42 am

straightlight wrote:
Mon Dec 18, 2017 6:36 am
In addition, take note that the system/storage folder must be located outside of your public_html folder. Then, to edit your config.php and admin/config.php files to adjust the new storage path accordingly. Then, to clear your cache after logging out of your Opencart admin session. Take note that the above error messages also shows the modification folder which means being caused by an installed extension and not only by the custom theme.
Thank you for the extra info. Just to check, should i move the storage folder as it is and edit the config or just create a new folder and let opencart recreate the directories within it?

And second, if am to move the storage folder should i delete the cache folder then refreshing the modification button will recreate the cache folder and everything within?

Newbie

Posts

Joined
Mon Jan 30, 2017 7:04 am


Post by straightlight » Mon Dec 18, 2017 6:48 am

Just to check, should i move the storage folder as it is and edit the config or just create a new folder and let opencart recreate the directories within it?
Simply move the storage folder along with the sub-folder outside your public_html folder from your host file manager console (not from FTP). Then, set your CHMOD setting on your storage folder to 0755 recursively. This should take less than 10 seconds operation to do. Then, edit your config.php and admin/config.php files storage paths (each defined constants of both files).

As for the cache, yes - the modification button is included in the process. Although, ensure to have your latest XML modifications aside since your extension settings could completely reset to its original state from the modifications page in the admin.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 11 guests