Post by LuisaX » Tue Nov 07, 2017 11:37 pm

Hello!
I noticed recently that suddenly some orders(from end of October/beginning of November) went directly to missing orders even if the payment has been done.
Any suggestions about it? I'm using open cart 2.3.0.2
This is a real problem for me 'cause now i've to check each order if there is the payment in paypal.
Please help!

Thanks

User avatar
New member

Posts

Joined
Fri Feb 19, 2016 4:53 pm

Post by thekrotek » Wed Nov 08, 2017 12:41 am

If you set all statuses in PayPal extension properly, then it's hard to say, what exactly can be the issue in your case. Every case is different, plus it depends on PayPal extension you're using.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by LuisaX » Wed Nov 08, 2017 5:30 am

Hi
I installed Paypal standard in my Opencart and it always worked very well. I noticed also that IPN on paypal setting were disabled . This is happening from time to time . I activated IPN now so i hope it'll work again.
Many thanks for your answer !


User avatar
New member

Posts

Joined
Fri Feb 19, 2016 4:53 pm

Post by thekrotek » Wed Nov 08, 2017 6:49 am

Yes, IPN must be enabled. PayPal sends transaction data via IPN, so if you disable it, your store won't never know anything about any transaction.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by LuisaX » Wed Nov 08, 2017 6:36 pm

I'm actually using this address https://www.malleusdelic.com/store/inde ... d/callback
I contacted paypal and they told me there is 404 error for some transactions.
I think the Url is correct but i'm not sure anymore. As i told you i'm using standard Paypal module and i don't have any options about IPN in Opencart.
Do you have any suggestions?

Thank you again!


User avatar
New member

Posts

Joined
Fri Feb 19, 2016 4:53 pm

Post by thekrotek » Wed Nov 08, 2017 6:49 pm

URL looks legit, yes. If only some transactions failed, then it's just a temporary connection issue, nothing more.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by LuisaX » Wed Nov 08, 2017 7:06 pm

Is it normal that if i click on that url there is an error "The page you requested cannot be found!" ?
I think this could be the problem but honestly i don't know how to solve it
Thanks


User avatar
New member

Posts

Joined
Fri Feb 19, 2016 4:53 pm

Post by straightlight » Thu Dec 07, 2017 2:09 am

What do you see in the most recent access log entries of your webserver when noticing The page you requested cannot be found! message on your browser?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 26 guests