Post by KDNovelties » Tue Oct 24, 2017 4:19 am

Takes a long time just getting to the modifications page. Takes just as long clearing and refreshing. Anything I can do to speed it up?
Thanks

User avatar
New member

Posts

Joined
Sat May 27, 2017 12:12 am

Post by IP_CAM » Tue Oct 24, 2017 7:14 am

Yep , place a link to your Site, so we don't have to waste time,
trying to find out by writing back and forth! :laugh:
Ernie

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
-
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
-
1'300+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by paulfeakins » Tue Oct 24, 2017 4:43 pm

Sounds like you're on slow hosting?

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by KDNovelties » Tue Oct 24, 2017 9:57 pm

OK, lets try this again. This is the modifications page in the admin... Not sure how posting the site would help, but it is www.kdnovelties.com. Also, the site itself loads quickly and we're in the high 90s for all page speed tests... So that rules out the hosting provider...

Thanks

User avatar
New member

Posts

Joined
Sat May 27, 2017 12:12 am

Post by IP_CAM » Tue Oct 24, 2017 11:30 pm

Well, you may be in the high 90es in Google Check Mobile View, but on other
Test Sites, it sometimes looks a little different. It's also the result of the gigantic
Javascript in the header. To compress too many scripts into one does not only
have advantages, since all of them are then placed into the header part, beeing
called by every single pageload, regardless of, if they are used on certain pages
or not.
Among other small misses, even broken links and a bunch of redirects exist,
when checking category Pages. And this is what I usually do, because a Main Page
is only called once by a visitor, so, those Pages, used most, should load exellent ...
Google is the Best in producing search results, but when it comes to test Pages,
they are, at best, about ranking in Place 5 !
Good Luck!
Ernie
PS: Nothing personal, and it only concerns the front ! :D
---
https://gtmetrix.com/reports/www.kdnove ... m/FruRHSFz
https://tools.pingdom.com/#!/dxXEI/http ... tional-dvd
---
Image

Attachments

testmysite_performance_results.jpg

testmysite_performance_results.jpg (42.13 KiB) Viewed 1178 times


I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
-
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
-
1'300+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by KDNovelties » Wed Oct 25, 2017 12:08 am

Ernie, thanks for this information and yes, nothing personal, I appreciate the response and help.

Sadly, I need the redirects as the site structure has changed and the old urls are listed everywhere. I do have those redirects in the database using an extension and not in the htaccess file. But even turning this extension off did not help. I have a test site which is an exact replica, except for a few extension that are not there since they require a site licenses, these being NitroPack and AbandonedCarts by iSenseLabs. I'm not sure if these would be the cause, but clearing the cache and refreshing on the test site is instant. Mind you, it wasn't always like that (the test site). When I finished developing in test and went live to the new site, the test site was just as slow, but the live site was fast. Then I rebuilt the test site last week, importing the database from the live, and everything was fast again. The live site has gotten slower over time. We've only been live 2 months with OC. I was hoping there was a way to speed it up. I'm new to OC coming from CubeCart (old version 4x), and don't know OC well yet.

Thanks again for the help. Looking at your profile, I see we have similar backgrounds. I too have been a Computer-Freak since the 70s. Although I gravatated towards networking instead of programming.

Do you do site optimizations as far as speed is concerned? If so, PM or email me pricing and a list of what is included.

Thanks
Angel

User avatar
New member

Posts

Joined
Sat May 27, 2017 12:12 am

Post by IP_CAM » Wed Oct 25, 2017 3:49 am

Sorry, but I never touched Nitro-Pack, it's hard enough for an old colorblind
Hobby-Coder, to find his way by going 'step by step', and as close to oc-default
as possible. And if one uses NirtroPack, one should better not play around the
'manual' way too, it could have a negative overall-effect on performance.

Only after 'refining' everything else, I am gonna decide on, what Code shall be
combined, and in wich form, in order to avoid long loading time in any section.
Exept for the Product Page, there, it does not matter, timewise at least ... :D

So, globally 'assigned' modification of code, as it possibly can be set in Nitro,
may not be the upmost 'speadiest' solution. It all depends on, what one offers
on Products and other 'Results' on a Page, and how heavy sized images one uses.
Also, additional Extensions or Custom Themes will have an effect on performance.

But when it comes to all those shiny Gizmo's on a Page, linking to somewhere,
likely even executing remotly placed Pic's and JS as well, then, one has a Problem,
because Test-Sites don't like such very much, since they all only act as brakes, and
should therefore better not even be placed in socalled key-pages.

So, what should I say more, check on GTMetrix, they are the most detailled, when it
comes to explaining, what and where something needs to be done. Then, if you have
specific questions on details like size-untagged images or .htaccess hints, you likely
get some answers here.

And regarding Googie, if I need 500 Thumbs weight-reduced at once, I use it, to then
temporarely produce a 98 - 99 on GTMetrix Pageload, but other than that, I don't care,
if Google donates a 75%(M) + 90%(W) Rating, as long as I get an 88%(M) + 98%(W)
Rating for the same category Page at GTMetrix, and usually 100% overall at Pigdom.

Good Luck ! ;)
Ernie
---
Image

Attachments

pingdom_eveli_li_performance_results.jpg

pingdom_eveli_li_performance_results.jpg (51.91 KiB) Viewed 1148 times


I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
-
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
-
1'300+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Johnathan » Wed Oct 25, 2017 5:44 am

Pro tip: you probably have a huge ocMod log file. If you delete that in the "Log" tab it should speed up to a normal page load speed.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by EvolveWebHosting » Wed Oct 25, 2017 7:51 am

Johnathan wrote:
Wed Oct 25, 2017 5:44 am
Pro tip: you probably have a huge ocMod log file. If you delete that in the "Log" tab it should speed up to a normal page load speed.
Good point as most over look this.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by KDNovelties » Thu Oct 26, 2017 7:57 am

Johnathan wrote:
Wed Oct 25, 2017 5:44 am
Pro tip: you probably have a huge ocMod log file. If you delete that in the "Log" tab it should speed up to a normal page load speed.
BINGO! That solved the issue!
Many thanks!
Angel

User avatar
New member

Posts

Joined
Sat May 27, 2017 12:12 am

Post by arcovirtual » Thu Mar 28, 2019 2:45 am

Johnathan wrote:
Wed Oct 25, 2017 5:44 am
Pro tip: you probably have a huge ocMod log file. If you delete that in the "Log" tab it should speed up to a normal page load speed.
wow 3 year search solution for this problem and you resolved, all ok thk master god!!!!!!!

New member

Posts

Joined
Thu Jul 07, 2016 9:49 am

Post by Johnathan » Thu Mar 28, 2019 9:57 pm

Ha, glad I could help. I'll be adding an automatic refresh of that log to my OpenCart Admin Improvements, since this happens to lots of people and they don't realize the cause. There's no real reason it needs to be stored forever, just for the last refresh, so that should help address it.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by normdouglas » Tue Nov 12, 2019 3:28 am

Johnathan wrote:
Thu Mar 28, 2019 9:57 pm
Ha, glad I could help. I'll be adding an automatic refresh of that log to my OpenCart Admin Improvements, since this happens to lots of people and they don't realize the cause. There's no real reason it needs to be stored forever, just for the last refresh, so that should help address it.
Oh Mr Johnathan... you've done it again.
I think the OP wasn't asking about page speed, rather they were asking about MODFICATIONS page in the backend speed.
I've experienced this forever... and I just put it down to how many vqmods I have running... clearing the log has made such a massive difference.
Now to find our how to TURN OFF modifications cache logging.

New member

Posts

Joined
Sat Apr 06, 2013 5:22 am
Location - Australia
Who is online

Users browsing this forum: No registered users and 10 guests