Post by jokernippe » Thu May 11, 2017 12:54 am

Hi,

I get this code when I open my shop www.hangonpuukko.fi/shop

Notice: Undefined index: english in /home/hangonpu/public_html/shop/catalog/controller/startup/startup.php on line 106

Warning: Cannot modify header information - headers already sent by (output started at /home/hangonpu/public_html/shop/catalog/controller/startup/startup.php:106) in /home/hangonpu/public_html/shop/catalog/controller/startup/startup.php on line 156


What should I do to het the Page to work!!!


Thanks!!!!

Active Member

Posts

Joined
Fri Aug 02, 2013 1:44 am

Post by MrPhil » Thu May 11, 2017 1:09 am

Don't worry about the "headers not sent" second error message. Clean up the first error (missing index "english") and the second will go away. You have similar errors all over the page, so there's probably something in common with their cause. Maybe you're missing an include file that defines these language strings? This shop is just being installed, and has not been running yet?

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by jokernippe » Thu May 11, 2017 1:23 am

The shop has been about 2 years but I took the ENG to use and the error code came... But If I remove the ENG the code is still there...

What should I do? I'm not so goood with the codes..
And many customers have also problems when they are going in to see a product everything is almost blank on the page... Is that because the error code?

Thanks!!

Active Member

Posts

Joined
Fri Aug 02, 2013 1:44 am

Post by jokernippe » Thu May 11, 2017 1:30 am

And this code...

Notice: Undefined index: english in /home/hangonpu/public_html/shop/catalog/controller/startup/startup.php on line 106

Warning: Cannot modify header information - headers already sent by (output started at /home/hangonpu/public_html/shop/catalog/controller/startup/startup.php:106) in /home/hangonpu/public_html/shop/catalog/controller/startup/startup.php on line 156
Notice: Undefined index: product_id in /home/hangonpu/public_html/shop/catalog/controller/pavdeals/deals.php on line 293
Fatal error: Uncaught exception 'Exception' with message 'Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND o.order_status_id=1' at line 2<br />Error No: 1064<br />SELECT sum(quantity) as total FROM `oc_order_product` op LEFT JOIN `oc_order` AS o ON op.order_id = o.order_id WHERE op.product_id = AND o.order_status_id=1' in /home/hangonpu/public_html/shop/system/library/db/mysqli.php:40 Stack trace: #0 /home/hangonpu/public_html/shop/system/library/db.php(16): DB\MySQLi->query('SELECT sum(quan...', Array) #1 /home/hangonpu/public_html/shop/catalog/model/pavdeals/product.php(126): DB->query('SELECT sum(quan...') #2 [internal function]: ModelPavdealsproduct->getTotalBought(NULL, 1) #3 /home/hangonpu/public_html/shop/system/engine/loader.php(178): call_user_func_array(Array, Array) #4 [internal function]: Loader->{closure}(Array, Array) #5 /home/hangonpu/public_html/shop/system/engine/proxy.php(25): call_user_func_array(Object( in /home/hangonpu/public_html/shop/system/library/db/mysqli.php on line 40

Active Member

Posts

Joined
Fri Aug 02, 2013 1:44 am

Post by MrPhil » Thu May 11, 2017 1:39 am

Can you roll back your changes so you at least have the shop working again? Then you can calmly go through the process, preferably on a test version of your shop (e.g., in a /test directory), of seeing how to configure for English. I suspect that somewhere you need a file that loads the English text strings, but your installation is incomplete and the file is missing or is empty.

I'm just starting out in OC myself, so at this point I can't help with specific file information or what to look for. Hopefully someone else can help with that.

Once you've cleaned up the problem causing the very first error, don't be surprised if all the errors have gone away!

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by paulfeakins » Thu May 11, 2017 5:27 pm

jokernippe wrote:
Thu May 11, 2017 12:54 am
What should I do to het the Page to work!!!
You haven't included any info about what OpenCart version you're using or what extensions.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 38 guests