Page 2 of 2

Re: I've tried everything! Warning: You do not have permission to access the API!

Posted: Sat Apr 21, 2018 12:36 am
by Leoden
go to system -> users -> API and make sure the default is enabled and save it.
go to system -> settings -> options and scroll down to Checkout and make sure that the API User is set to Default from the dropdown list and save it.
when you get the warning click on add IP.
that's it enjoy...

Re: I've tried everything! Warning: You do not have permission to access the API!

Posted: Wed Apr 25, 2018 11:51 pm
by Storeship
Has anyone actually got this to work?
I have obtained a token ok using an API call but when i try and get Orders i get the permission problem (You do not have permission to access the API!).
I am using a third party website to connect to a fresh Opencart 2.3.0.2 installation.
It is something to do with the session, tbh i am fed up with having to debug code from an established script, SSL doesnt work correctly, API doesnt work, i have spent hours on this..

Re: I've tried everything! Warning: You do not have permission to access the API!

Posted: Thu Apr 26, 2018 12:04 am
by thekrotek
Disable API checks or redefine api_I'd session variable in api/login.php file. In OC 2.3 API sessions are broken, it's a well known issue.

Re: I've tried everything! Warning: You do not have permission to access the API!

Posted: Thu Apr 26, 2018 11:46 pm
by paulimoke
Try this it may work for you:
Go to System>Settings>then select store and edit
Then go to the option tab and select API User and set it to default,
save and it should work