Page 1 of 1

SOLVED : Opencart cannot complete purchase

Posted: Wed Apr 26, 2017 2:35 am
by sdancer75
Version 2.3.0.2

I created a virtual product for downloading. The problem is that opencart could not complete the purchase.

At the final step "Complete Purchase" when I click on that button it says "loading..." for a sec and then it returns back to the "Complete Purchase".

What seems to be the problem in my situation ?

Best Regards,

Re: Opencart cannot complete purchase

Posted: Wed Apr 26, 2017 7:32 am
by Agit
Can you send me you web site url ?
Chrome bug tracker i can found error.

SOLVED: Opencart cannot complete purchase

Posted: Wed Apr 26, 2017 10:36 pm
by sdancer75
Hi,

It seems that something wrong with the cheque payment extention. Store, receive the order normally and I can see them in the admin side, but it never shows the confirmation success message.
GET index.php?route=extension/payment/cheque/confirm&_=1493223038590
500 Internal Server Error
235ms
I am too lazy to debug the code right now, so if you can recommend a quick but not dirty solution, it would be wonderful.

------------------- EDIT -----------------------

Looking at the logs I found out that the problem was the line
/opencart/catalog/model/checkout/order.php(658): Mail->send()
So, I fixed the SMTP mail account at the admin->System->Settings->Mail and the problem solved !

Regards,

Re: SOLVED: Opencart cannot complete purchase

Posted: Wed Jun 24, 2020 8:06 am
by Mustafa Wrya
sdancer75 wrote:
Wed Apr 26, 2017 10:36 pm
Hi,

It seems that something wrong with the cheque payment extention. Store, receive the order normally and I can see them in the admin side, but it never shows the confirmation success message.
GET index.php?route=extension/payment/cheque/confirm&_=1493223038590
500 Internal Server Error
235ms
I am too lazy to debug the code right now, so if you can recommend a quick but not dirty solution, it would be wonderful.

------------------- EDIT -----------------------

Looking at the logs I found out that the problem was the line
/opencart/catalog/model/checkout/order.php(658): Mail->send()
So, I fixed the SMTP mail account at the admin->System->Settings->Mail and the problem solved !

Regards,
thank you for posting your solution it helped mine !