Post by Rainforest » Wed Mar 22, 2017 6:17 am

I'm having a problem with my Top Administrator permissions after installing and uninstalling a module.

The three permissions that allow me to edit a user keep unchecking by themselves.
So, when I try to edit a user, I get permission warning.

Any ideas?
Yes, I've tried to add the default permissions and even added the permissions manually in PHPmyAdmin but they just uncheck.
Any assistance is appreciated!

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by henryscart » Fri Jun 16, 2017 8:07 pm

Same issue.
Some of the user permissions uncheck, of which one is the "modify user permissions" - permission.
Also I get white screen on mod refresh.

oc2302

New member

Posts

Joined
Thu Apr 11, 2013 8:23 pm

Post by thekrotek » Fri Jun 16, 2017 9:42 pm

You sure they're "unchecked", not simply not working? Because there's an issue with certain extensions, when permissions are defined on install and then somehow "lost". As far as I'm concerned, nobody was able to find out the root of the issue, because it's super random.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by henryscart » Fri Jun 16, 2017 11:17 pm

Yes, 100% sure they are unchecked.
Just now I
- created a new user in database,
- created a new user group,
- added default permissions,
- logged in as the new user and
- set full permissions to bort view and modify
Got accepted and verified that they where still checked for this user.

I then tried to check and save the permissions for the Administrator user group - not allowed due to permissions (these where just OK).
When I swiched back to the new user group some permissions in "modify" where unchecked - hence this user can no longer edit permissions, api, user groups etc (it's a couple of boxes at the bottom of the list).

New member

Posts

Joined
Thu Apr 11, 2013 8:23 pm

Post by henryscart » Sun Jun 18, 2017 7:52 pm

Not really sure what's going on but tried this:
- deactivated all custom vqmods - no change to the problem
- rolled back the Engine setting to MYISAM for table user_group (I had previously changed most table engines to innoDB). Did this since the permissions field is "text". - No obvious change to the problem.
- re-entered the missing permissions to the text field permissions in database - the checkboxes where now checked AND was able to save without them being unchecked. Was also able to check permissions to another user group and save without anything being unchecked (as while writing this at least).
- was now able to create API and set the API to user in order to update order etc.
- have re-activated each vqmod clearing cache and testing for each one - still working full permissions.

About the white screen on mods refresh:
For ones I now got an error (other than white screen/500 ISE) : "ERR-CACHE-MISS"
According to this there is a bug in chrome... https://stackoverflow.com/questions/265 ... cache-miss
... so I tried in Firefox which let's me look at the list of mods and clear cache, but still white page on refresh.

To be continued I guess

New member

Posts

Joined
Thu Apr 11, 2013 8:23 pm

Post by cmerry » Tue Jun 20, 2017 5:01 pm

Go to "user_group" db table and change data type of "permission" column from TEXT to MEDIUMTEXT. This should be in OC by default because TEXT column have maximum length of 65,535 characters and in many cases It is not enough If you have many extensions installed. MEDIUMTEXT column have maximum length of 16,777,215 characters.


User avatar
Active Member

Posts

Joined
Sat Jul 17, 2010 8:42 pm

Post by henryscart » Tue Jun 20, 2017 10:09 pm

cmerry wrote:
Tue Jun 20, 2017 5:01 pm
Go to "user_group" db table and change data type of "permission" column from TEXT to MEDIUMTEXT. This should be in OC by default because TEXT column have maximum length of 65,535 characters and in many cases It is not enough If you have many extensions installed. MEDIUMTEXT column have maximum length of 16,777,215 characters.
Thanks for advice!
Character count is currently 49063, but changed anyway as an experiment/precaution.
- The permission checkboxes remain checked as they should.
- Still white page on mods refresh (maybe not very likely that changing the row Type would solve that one, but worth a try).

New member

Posts

Joined
Thu Apr 11, 2013 8:23 pm

Post by cmerry » Wed Jun 21, 2017 1:03 am

henryscart wrote:
Tue Jun 20, 2017 10:09 pm
- Still white page on mods refresh (maybe not very likely that changing the row Type would solve that one, but worth a try).
Delete all folders in system/storage/modification/ except index.html. After this refresh mods.


User avatar
Active Member

Posts

Joined
Sat Jul 17, 2010 8:42 pm
Who is online

Users browsing this forum: No registered users and 15 guests