Page 1 of 1

Template banner keeps flashing off and on??

Posted: Sat Feb 11, 2017 4:49 am
by robocop1953
Using O/C 2.3.0 standard default template. The included banner 'HP Products' that appears lower left of category list / category pages keeps flashing in and out? What is causing this and how can I edit to appear static?

Re: Template banner keeps flashing off and on??

Posted: Sat Feb 11, 2017 7:21 pm
by thekrotek
Most likely it's due to low browser resources or too many JS on the page.

Re: Template banner keeps flashing off and on??

Posted: Sun Feb 12, 2017 6:51 am
by agatha65
This is a bug in all 2 versions.
Here is the fix:

Re: Template banner keeps flashing off and on??

Posted: Mon Feb 13, 2017 4:13 am
by thekrotek
agatha65 wrote:This is a bug in all 2 versions.
Here is the fix:
banner_fix_stop_animation.ocmod.xml
Really? Why I never saw this bug on any OC 2 version? It might be related to some specific setup, I guess.

Re: Template banner keeps flashing off and on??

Posted: Mon Feb 13, 2017 3:42 pm
by agatha65
The issue appears when only one banner image is set. The slider is flashing and this is not a specific setup.
You can check github. It is in all versions starting 2.0.1.0 to 2.3.0.2 which use owl carousel in banner.tpl.

Re: Template banner keeps flashing off and on??

Posted: Mon Feb 13, 2017 9:29 pm
by robocop1953
Thanks.....I uploaded the .xml provide but the problem still occurs? Only with one of the minor banners within the 'categories' pages (see small banner lower left): http://mwarda.com/index.php?route=produ ... path=20_26 Have tested in various browsers and the problem exists regardless.

Re: Template banner keeps flashing off and on??

Posted: Wed Mar 08, 2017 7:20 pm
by malam
hi, I just try it and doesn't work, any other solution please?

malam

Re: Template banner keeps flashing off and on??

Posted: Tue May 08, 2018 4:25 pm
by sketchi
malam wrote:
Wed Mar 08, 2017 7:20 pm
hi, I just try it and doesn't work, any other solution please?
Agatha65's mod worked for me in 2.3.0.2 after changing the path from:

<file path="catalog/view/theme/*/template/module/banner.tpl">

to:

<file path="catalog/view/theme/*/template/extension/module/banner.tpl">