Post by caver911 » Thu Jan 12, 2017 6:11 pm

version 2.3.0.2

Images of the errors are attached, look also on them. I fixed many errors but the following "JSON" I do not have experience with... Also notes in bottom regards to what is done.

Administration category Order, subcategory Addorder :
SyntaxError: Unexpected end of JSON input

Administration category Order, subcategory Vouchers:

SyntaxError: JSON parse: unexpected character at line 1 column 1 at the JSON data
OK

Currency.php errors from administration logg:
See the attached image. I suspect this appear because of the JSON errors.

Notes:
I have all translated admin language files and updated admin. In this set up I configured new language as default store location, currency and other. I also deleted the USD as currency and created it on new (This so site read new language and currency as default). I am not sure what the JSON is error is. JSON is this a file?


I also installed extensions that works flawless.

The same errors appears on to different installation using the same installation files. So the errors probably is in some of the files regards to "JSON" I suspect.

Attachments

currency.php error.jpg

currency.php error.jpg (188.61 KiB) Viewed 597 times

Syntax error_order_cart_voucher.jpg

Syntax error_order_cart_voucher.jpg (262.71 KiB) Viewed 597 times

Syntax error_order_add order.jpg

Syntax error_order_add order.jpg (171.96 KiB) Viewed 597 times

Last edited by caver911 on Fri Jan 13, 2017 5:23 pm, edited 1 time in total.

New member

Posts

Joined
Thu Dec 15, 2016 4:36 am

Active Member

Posts

Joined
Wed Aug 29, 2012 7:53 pm

Post by caver911 » Fri Jan 13, 2017 5:05 am

The first error happens in admin sales>orders>add new (The next page page that should appear when clicking the + icon on the add new icon

Can someone help me with the name of file tand which folder o find it. This so I can view the coding to find the error.

Same with error two that appears in sales>orders>gift vouchers The file name of page that should appear when clicking on mail icon in the gift vouchers page.It gives also a ONS error.

If I can find the files I would beleave that I might could find the errors creating the errors.

Appreciate any help and direction.

New member

Posts

Joined
Thu Dec 15, 2016 4:36 am

Post by caver911 » Fri Jan 13, 2017 6:03 am

ralphstirrat wrote:this page might be of some help
http://www.opencartnews.com/tutorials/c ... olve-them/
Thanks for help, but the errors was not listed in the article. Still will appreciate some more help/advice.

New member

Posts

Joined
Thu Dec 15, 2016 4:36 am

Post by ralphstirrat » Fri Jan 13, 2017 5:53 pm

Have you tried this "I have refreshed currency values manually (system>localisation>currencies) and the error seems to have vanished. "

viewtopic.php?f=191&t=163393

http://colbrook.co.uk


Active Member

Posts

Joined
Wed Aug 29, 2012 7:53 pm
Who is online

Users browsing this forum: No registered users and 12 guests