Post by satriani » Tue Oct 04, 2016 2:00 am

I have a very strange problem in opencart script 2.1.0.2, when i am trying to save related products in admin.

The problem: e.g
1. I select 2 related products and save them. (everything ok so far)
2. I re-open the product and then make some changes in the product form elsewhere.
3. I re-save it
4. When i re-open the product, the changes in related products have been lost. (related products empty)

I see in the error log the following errors that are related:

PHP Notice: Undefined index: product_id in /home/xxx/public_html/vqmod/vqcache/vq2-admin_view_template_catalog_product_form.tpl on line 418
PHP Notice: Undefined index: product_id in /home/xxx/public_html/vqmod/vqcache/vq2-admin_view_template_catalog_product_form.tpl on line 417

I have disabled all extentions, i even overwrited product_form.tpl with the original one from opencart, but nothing.

Any ideas?

Newbie

Posts

Joined
Tue Mar 05, 2013 3:29 am

Post by AlexDW » Tue Oct 04, 2016 5:55 pm

Compare your file admin\controller\catalog\product.php with original file from distributive.
Try to replace him and refresh modification cache.

(make copy of your file before replacing)

Useful Opencart extensions


User avatar
New member

Posts

Joined
Sun Jun 05, 2016 3:32 am

Post by AlexDW » Tue Oct 04, 2016 6:04 pm

Ha, I noticed nickname just now.. :D
The issue was resolved, the reason was a modified file as I wrote earlier

Useful Opencart extensions


User avatar
New member

Posts

Joined
Sun Jun 05, 2016 3:32 am

Post by gokaydemir86 » Sun Nov 12, 2017 2:04 pm

AlexDW wrote:
Tue Oct 04, 2016 5:55 pm
Compare your file admin\controller\catalog\product.php with original file from distributive.
Try to replace him and refresh modification cache.

(make copy of your file before replacing)
Hi AlexDW, could you have a look at my problem please :
viewtopic.php?f=190&t=199535
Dear straightlight made an effort for me, but we couldn't get the solution. Thank you very much..

Newbie

Posts

Joined
Tue Jul 18, 2017 8:08 am

Post by straightlight » Sun Nov 12, 2017 11:27 pm

gokaydemir86 wrote:
Sun Nov 12, 2017 2:04 pm
AlexDW wrote:
Tue Oct 04, 2016 5:55 pm
Compare your file admin\controller\catalog\product.php with original file from distributive.
Try to replace him and refresh modification cache.

(make copy of your file before replacing)
Hi AlexDW, could you have a look at my problem please :
viewtopic.php?f=190&t=199535
Dear straightlight made an effort for me, but we couldn't get the solution. Thank you very much..
And where was it indicated that the problem could not be solved previously?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by gokaydemir86 » Mon Nov 13, 2017 3:49 am

straightlight wrote:
Sun Nov 12, 2017 11:27 pm
gokaydemir86 wrote:
Sun Nov 12, 2017 2:04 pm
AlexDW wrote:
Tue Oct 04, 2016 5:55 pm
Compare your file admin\controller\catalog\product.php with original file from distributive.
Try to replace him and refresh modification cache.

(make copy of your file before replacing)
Hi AlexDW, could you have a look at my problem please :
viewtopic.php?f=190&t=199535
Dear straightlight made an effort for me, but we couldn't get the solution. Thank you very much..
And where was it indicated that the problem could not be solved previously?
Please don't misunderstand me. When you shared the "QuickSave Extension" of AlexDW, I thought that he maybe exprerienced about this arguement. So I am sorry if I made you misunderstand me :(

Newbie

Posts

Joined
Tue Jul 18, 2017 8:08 am
Who is online

Users browsing this forum: No registered users and 46 guests