Post by fiif » Tue Sep 27, 2016 4:27 pm

A number of websites with open cart are having issues since upgrading from php 5.4 to 5.6, we are getting the below error:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO...

I can see there was a thread on this previously : http://forum.opencart.com/viewtopic.php?f=20&t=163163 however no fix was given at that time. Does anyone have a quick run down on what will need to be done to update the install to run using 5.6 or is there an article I would be able to reference? I will be unable to give FTP logins to these accounts

Any help would be very much appreciate

Newbie

Posts

Joined
Tue Sep 27, 2016 4:20 pm

Post by villagedefrance » Tue Sep 27, 2016 8:52 pm

Like the error message says, MySql database is deprecated. MySqli or PDO are the answer.

Basically it looks like you need to backup all your data, do a clean install using MySqli (or PDO) and re-inject your data in your tables. There is obviously a risk of losing data ...

OpenCart custom solutions @ https://villagedefrance.net


User avatar
Active Member

Posts

Joined
Wed Oct 13, 2010 10:35 pm
Location - UK

Post by Avvici » Tue Sep 27, 2016 9:40 pm

Perhaps it is also interesting to know exactly why it shows up. The entire ext/mysql PHP extension, which provides all functions named with the prefix mysql_, was officially deprecated in PHP v5.5.0 and removed in PHP v7.

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC
Who is online

Users browsing this forum: No registered users and 31 guests