Post by hayridumanli » Thu Aug 18, 2016 10:12 pm

Hi,
My website started to give error immediately, it was working yesterday, the website is:
http://www.lokmanhekimkibris.com

And the error is;
Fatal error: Call to undefined function utf8_substr() in /home/lkmncom/public_html/catalog/model/tool/image.php on line 11

And I cannot login to admin, too. I write down the username and password, then it shows blank (white page). When I check the error.log, it writes the same error;
PHP Fatal error: Call to undefined function utf8_substr() in /home/lkmncom/public_html/admin/model/tool/image.php on line 11

Thank you in advance for your help.

Newbie

Posts

Joined
Fri Jul 22, 2016 9:12 pm

Post by AlexDW » Fri Aug 19, 2016 5:01 pm

Check the existence of file system\helper\utf8.php

If not - copy him from your OC version distributive

Useful Opencart extensions


User avatar
New member

Posts

Joined
Sun Jun 05, 2016 3:32 am

Post by knowband.plugins » Fri Aug 19, 2016 5:19 pm

Kindly ensure that following file is present on your server.

/system/startup.php

If it is not there, download the same version of Opencart from official store and restore this file from there.

let us know if it doesn't help.

Regards,
Knowband Team

Opencart Plugins: Knowband Store
Email: support@knowband.com


User avatar
Active Member

Posts

Joined
Thu Aug 04, 2016 2:56 pm


Post by hayridumanli » Fri Aug 19, 2016 8:32 pm

AlexDW wrote:Check the existence of file system\helper\utf8.php
If not - copy him from your OC version distributive
utf8.php was there, but copied and overwritten again. Then website gave blank page, here is the error.log;
[19-Aug-2016 12:30:54 UTC] PHP Warning: require_once(/home/lkmncom/public_html/system/engine/proxy.php): failed to open stream: No such file or directory in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116
[19-Aug-2016 12:30:54 UTC] PHP Fatal error: require_once(): Failed opening required '/home/lkmncom/public_html/system/engine/proxy.php' (include_path='.;/path/to/php/pear') in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116
[19-Aug-2016 12:30:56 UTC] PHP Warning: require_once(/home/lkmncom/public_html/system/engine/proxy.php): failed to open stream: No such file or directory in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116
[19-Aug-2016 12:30:56 UTC] PHP Fatal error: require_once(): Failed opening required '/home/lkmncom/public_html/system/engine/proxy.php' (include_path='.;/path/to/php/pear') in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116

Newbie

Posts

Joined
Fri Jul 22, 2016 9:12 pm

Post by hayridumanli » Fri Aug 19, 2016 8:33 pm

knowband.plugins wrote:Kindly ensure that following file is present on your server.
/system/startup.php
If it is not there, download the same version of Opencart from official store and restore this file from there.
let us know if it doesn't help.
startup.php was there, but copied and overwritten again. Then website gave blank page, here is the error.log;
[19-Aug-2016 12:30:54 UTC] PHP Warning: require_once(/home/lkmncom/public_html/system/engine/proxy.php): failed to open stream: No such file or directory in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116
[19-Aug-2016 12:30:54 UTC] PHP Fatal error: require_once(): Failed opening required '/home/lkmncom/public_html/system/engine/proxy.php' (include_path='.;/path/to/php/pear') in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116
[19-Aug-2016 12:30:56 UTC] PHP Warning: require_once(/home/lkmncom/public_html/system/engine/proxy.php): failed to open stream: No such file or directory in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116
[19-Aug-2016 12:30:56 UTC] PHP Fatal error: require_once(): Failed opening required '/home/lkmncom/public_html/system/engine/proxy.php' (include_path='.;/path/to/php/pear') in /home/lkmncom/public_html/vqmod/vqcache/vq2-system_startup.php on line 116

Newbie

Posts

Joined
Fri Jul 22, 2016 9:12 pm

Post by hayridumanli » Fri Aug 19, 2016 8:37 pm

But vq2-system_startup.php and proxy.php was there, too. I overwrote both files, then general.php gave error, I overwrote, too. Now we came back to same error in homepage;
Fatal error: Call to undefined function utf8_substr() in /home/lkmncom/public_html/catalog/model/tool/image.php on line 11

Newbie

Posts

Joined
Fri Jul 22, 2016 9:12 pm

Post by damodaranudas » Fri May 26, 2017 10:05 am

The following thread solved this issue in my case :)

https://stackoverflow.com/a/39671856/4656693

User avatar
Newbie

Posts

Joined
Tue Nov 20, 2012 1:20 am
Location - Colombia
Who is online

Users browsing this forum: No registered users and 40 guests