Post by donmck » Wed Jun 22, 2016 2:01 pm

Time-date problem in V2.x


Hi all,

I am using V2.1.0.2 of Opencart, and would like to know if users of V2.x are having similar problems.


Earlier this year, I had my Opencart hosted at Hostgator, and they set up the cart time for me on a local php.ini file.

I migrated across to SiteGround, and needed to adjust the time again, as the local php.ini file was no longer working correctly, and an edit and check on the .ini file didn't fix it.

SiteGround told me the easiest way of doing this is via the PHP Variables manager in Cpanel, and they completed this task for me, and all appeared to be working fine.

Some time later when I started to operate the cart, I noticed a two hour difference between the time shown in "Recent Activity" and the "Customers Online List".

The later was showing the correct time, and the "Recent Activity" was precisely two hours slow.

See added screen shots. Both are showing my test order and test customer, and are the same person or entry, "Don_OZ Test AU".

I wonder if users can indicate to me that they have similar problems in V2.x or specifically V2.1.0.2.

Any assistance very much appreciated.

Thanks in advance,

Cheers Don...
activity.jpg

activity.jpg (59.79 KiB) Viewed 1017 times

on-line.jpg

on-line.jpg (109.44 KiB) Viewed 1017 times

Last edited by donmck on Wed Jun 22, 2016 6:12 pm, edited 1 time in total.

New member

Posts

Joined
Thu Feb 26, 2015 11:52 am

Post by Burt65 » Wed Jun 22, 2016 2:11 pm

Hi Don...

There are two time in Opencart Your browser time and the server database time...

Use this extension and put the right AUS time in the setting and you will be fine...

http://www.opencart.com/index.php?route ... n_id=19781


Don't worry about the version number as it works with every OC version.

Cheers

Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

Post by donmck » Wed Jun 22, 2016 2:19 pm

Burt65 wrote:Hi Don...

There are two time in Opencart Your browser time and the server database time...

Use this extension and put the right AUS time in the setting and you will be fine...

http://www.opencart.com/index.php?route ... n_id=19781


Don't worry about the version number as it works with every OC version.

Cheers
That was a super quick answer Burt65. I'll give it a go, (in the next 1 or 2 days at this point) and let you know how it went.

Cheers Don...

New member

Posts

Joined
Thu Feb 26, 2015 11:52 am

Post by Burt65 » Wed Jun 22, 2016 2:22 pm

It looks like the extension in the comment for 2.x.x.x has been removed..

Use this xml attached here:


Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

Post by donmck » Wed Jun 22, 2016 2:46 pm

Hi Burt65

This URL:
http://www.opencart.com/index.php?route ... n_id=19781

asks you to go to this URL for V2.1
http://www.opencart.com/index.php?route ... n_id=25071
However this URL currently doesn't exist

You downloaded the one for the older versions and it worked OK for you then?

I searched and found this one:
http://www.opencart.com/index.php?route ... load_id=42

But as I have run out of time to do anything right now, I'll have a look at a later date.

Cheers Don...

New member

Posts

Joined
Thu Feb 26, 2015 11:52 am

Post by donmck » Wed Jun 22, 2016 2:50 pm

sorry Burt, I know I just wrote over the top of your last post. Both posting too quickly. :)

Not in a position to get to my cart for a few days, so I'll give it a try soon.

Cheers Don...

New member

Posts

Joined
Thu Feb 26, 2015 11:52 am

Post by Burt65 » Wed Jun 22, 2016 3:11 pm

donmck wrote:sorry Burt, I know I just wrote over the top of your last post. Both posting too quickly. :)

Not in a position to get to my cart for a few days, so I'll give it a try soon.

Cheers Don...
That's ok mate, just make sure you use the one in my post just above... I know it works with 2.1.0.2

Cheers

Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

Post by donmck » Wed Jun 22, 2016 4:13 pm

Sure Burt, as you can see it has been downloaded once, that's me :-)

Cheers Don...

New member

Posts

Joined
Thu Feb 26, 2015 11:52 am

Post by donmck » Wed Jun 22, 2016 6:11 pm

Hmmm....

My web developer man got to it before I was able to.
At cross purposes again.

However he installed:
http://www.opencart.com/index.php?route ... n_id=16023

and it is now working fine. at least we got a result.

Thanks Burt.

Cheers Don...

New member

Posts

Joined
Thu Feb 26, 2015 11:52 am
Who is online

Users browsing this forum: No registered users and 34 guests