Page 1 of 1

SSL giving 404 error on multi store

Posted: Thu May 19, 2016 1:27 pm
by moneycarlo
Hey all. Running 2.2.0.0..
Note: I'm tried to get ssl working on the cart pages first before trying to force on entire site.

So I have multi store set up. Main, default store(domain1.com), works fine. SSL is on and the https calls work successfully, cart pages load fine.
My second store(domain2.com) gives me 404 errors when i visit an https page (login, cart etc).
config.php files have https in the https sections in both admin and main folder:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.domain1.com/');
// HTTPS
define('HTTPS_SERVER', 'https://www.domain1.com/');
I have the Use SSL option enabled for both stores.
On my second store, i'm not certain what goes in the SSL URL field, but I've tried just a forward slash (it was defaulted there), i've tried my site (https://www.domain2.com), I've even tried the main store url (https://www.domain1.com).

I've even tried toggling off and on SEO URL's to no avail.

And now i'm out of ideas.
What else am i missing?

Re: SSL giving 404 error on multi store

Posted: Fri May 20, 2016 11:34 am
by moneycarlo
I also tried disabling SEO URL's and renaming .htaccess and still no luck.

Re: SSL giving 404 error on multi store

Posted: Fri May 20, 2016 7:22 pm
by Alex - A2Hosting
Can you send me a PM of both your websites? It could be a few things depending on different variables so with a link it should be easier to pinpoint the issue.

Re: SSL giving 404 error on multi store

Posted: Sat May 21, 2016 3:40 am
by moneycarlo
pm sent.
Thanks for your help.