Post by neddon » Sun May 15, 2016 5:16 am

Hello to everybody!

I have a problem with file manager window, Refresh and Parent buttons tooltip - the tooltip doesn't disappear on the second click!

But the main problem is that the tooltip doesn't disappear on closed file manager window!

Please, see the attached images..
opencart1.png

file manager image 1 - opencart1.png (38.72 KiB) Viewed 467 times

opencart2.png

file manager image 2 - opencart2.png (38.01 KiB) Viewed 467 times

opencart3.png

file manager image 3 - opencart3.png (40.75 KiB) Viewed 467 times

Can anyone help me or at least point me, which file is responsible for these buttons? All other buttons in file manager are working properly.

I use PHP version 5.6.20, tested Opencart version 2.1.0.2. and 2.2.0.0 (fresh install with demo products).

Thank you all in advance for your help!

Newbie

Posts

Joined
Sun Mar 27, 2016 7:58 am

Post by neddon » Sun May 15, 2016 10:54 am

I found the page..

admin> view> template> filemanager.tpl

The code is:

Code: Select all

        </div>
    <div class="modal-body">
      <div class="row">
        <div class="col-sm-5">

<a href="<?php echo $parent; ?>" data-toggle="tooltip" title="<?php echo $button_parent; ?>" id="button-parent" class="btn btn-default"><i class="fa fa-level-up"></i></a> 

<a href="<?php echo $refresh; ?>" data-toggle="tooltip" title="<?php echo $button_refresh; ?>" id="button-refresh" class="btn btn-default"><i class="fa fa-refresh"></i></a>

          <button type="button" data-toggle="tooltip" title="<?php echo $button_upload; ?>" id="button-upload" class="btn btn-primary"><i class="fa fa-upload"></i></button>
          <button type="button" data-toggle="tooltip" title="<?php echo $button_folder; ?>" id="button-folder" class="btn btn-default"><i class="fa fa-folder"></i></button>
          <button type="button" data-toggle="tooltip" title="<?php echo $button_delete; ?>" id="button-delete" class="btn btn-danger"><i class="fa fa-trash-o"></i></button>
        </div>
        <div class="col-sm-7">
          <div class="input-group">

            <input type="text" name="search" value="<?php echo $filter_name; ?>" placeholder="<?php echo $entry_search; ?>" class="form-control">
            <span class="input-group-btn">
            <button type="button" data-toggle="tooltip" title="<?php echo $button_search; ?>" id="button-search" class="btn btn-primary"><i class="fa fa-search"></i></button>
            </span></div>
        </div>
      </div>
Starting at row 6..

Search button also gives tooltip error!

Where is the cause of these errors?

I tested the Opencart demo and the result is the same as described above.

Let's fix this little bugs and make Opencart 2 the greatest ecommerce platform!

I am not a PHP programmer, so i am asking for help.

Newbie

Posts

Joined
Sun Mar 27, 2016 7:58 am
Who is online

Users browsing this forum: No registered users and 37 guests