Post by donaceli » Thu Apr 28, 2016 5:17 am

I hopes someone will be able to help me with this. I have upgraded to 2.2 from 2.0 and having an issue while trying to reset the password for a customer using the Forgot Your Password feature. AN errror reads:
Fatal error: Uncaught exception 'Exception' with message 'Error: Unknown column 'code' in 'field list'<br />Error No: 1054<br />UPDATE `oc_customer` SET code = 'LeI6lWkkWEzLj8hrKLBbvGcp5MQ1nlEp2QRGsxWv' WHERE LCASE(email) = 'donpoznanskis@icloud.com'' in /home/user/public_html/system/library/db/mysqli.php:40 Stack trace: #0 /home/user/public_html/system/library/db.php(16): DB\MySQLi->query('UPDATE `oc_cust...', Array) #1 /home/user/public_html/catalog/model/account/customer.php(108): DB->query('UPDATE `oc_cust...') #2 [internal function]: ModelAccountCustomer->editCode('donpoznanskis@i...', 'LeI6lWkkWEzLj8h...') #3 /home/user/public_html/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php(150): call_user_func_array(Array, Array) #4 [internal function]: Loader->{closure}(Array) #5 /home/user/public_html/system/engine/proxy.php(13): call_user_func(Object(Closure), Array) #6 /home/user/public_html/catalog/controller/account/forgotten.php(21): Proxy->__call('editCode', Array) #7 /home/user in /home/user/public_html/system/library/db/mysqli.php on line 40

Thank you for any help!

New member

Posts

Joined
Thu Jun 11, 2015 5:53 pm

Post by oc-extensions » Tue May 03, 2016 6:42 am

Hi,

In OC 2.2.0.0 table customer has column "code";
Your table customer seems don't have this column;

Check your table customer;

Good luck!

Image | Extensions and Custom Development


User avatar
Active Member

Posts

Joined
Fri Jan 06, 2012 11:31 pm

Post by donaceli » Thu May 19, 2016 7:39 pm

oc-extensions wrote:Hi,

In OC 2.2.0.0 table customer has column "code";
Your table customer seems don't have this column;

Check your table customer;

Good luck!
I'm not very comfortable with the tables. I have moved my tables one by one from oc 2.0.2.0 and don't have an original ones saved. How do I add the column code and where should I add it exactly? Is there any information that I need to plug in?

I really appreciate the time you spend helping me to sort this one out. Thank you.

New member

Posts

Joined
Thu Jun 11, 2015 5:53 pm

Post by donaceli » Thu May 19, 2016 10:44 pm

I have it sorted. Just added the code column manually into the table and all start working again.

New member

Posts

Joined
Thu Jun 11, 2015 5:53 pm
Who is online

Users browsing this forum: No registered users and 42 guests