Post by godesigns » Fri Mar 04, 2016 10:37 pm

I'm having an issue. I took the OpenCart main template and modified it to go inside a website I'm working on.

I add an item to the Cart and try and Check out.

Image

I can log in and then the next screen the tabs don't open.

Image

Any ideas?

Thanks
Gary Osterholt
Last edited by godesigns on Sat Mar 05, 2016 11:32 am, edited 1 time in total.

Newbie

Posts

Joined
Wed Jul 31, 2013 11:26 pm

Post by IP_CAM » Fri Mar 04, 2016 11:40 pm

> I took the OpenCart main template and modified it to go inside a website I'm working on. <

What is an Opencart Main Template, to be modified, to go into a Website ? :o
I assume, that you are just trying to achieve something, wich just does not function, by OC default.
And without looking at, what you did, noone around here would be able to assist, in the first place.
Ernie
openshop.li

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free Opencart LIGHT v.1.5.6.5_rc Software
can be seen in Action here: http://www.bigmax.ch
---
930+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by godesigns » Sat Mar 05, 2016 12:24 am

As far as the OpenCart Main Template...the one that keeps with the standard install.

I didn't touch any of the core files.

All I did was modified the header and footer to match an existing website.
I added all the CSS/JS files from the exist website into the header.

Image

I'd be more than happy to get any help. I believe it's a JavaScript conflict or some issue causing the CheckOut page not to work.

Thanks
Gary

Newbie

Posts

Joined
Wed Jul 31, 2013 11:26 pm

Post by IP_CAM » Sat Mar 05, 2016 8:16 am

you better link your site, instead of showing images, so, one can see, and so possibly find out, what you did...
Ernie

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free Opencart LIGHT v.1.5.6.5_rc Software
can be seen in Action here: http://www.bigmax.ch
---
930+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by godesigns » Sat Mar 05, 2016 8:27 am

IP_CAM wrote:you better link your site, instead of showing images, so, one can see, and so possibly find out, what you did...
Ernie
Actually the same thing is happening to a second store I'm working on.

Here's the link to that one.
http://www.merlinusa.com/e-store/index. ... t/checkout

Thanks
Gary

Newbie

Posts

Joined
Wed Jul 31, 2013 11:26 pm

Post by IP_CAM » Sat Mar 05, 2016 10:08 am

Header.tpl Code::

Code: Select all

<base href="<?php echo $base; ?>" /> 
Browser Source Code:

Code: Select all

<base href="http://www.jti.li/cart/" />
I just assume, that this MISSING Line above , in your Header.tpl, possibly prevents your shop
from 'acting/linking' according OC-Rules, especially, when it comes to execute JS/JSON - Code in some tasks.
But it's just a 'feeling', so, don't count on it ! :D
Ernie

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free Opencart LIGHT v.1.5.6.5_rc Software
can be seen in Action here: http://www.bigmax.ch
---
930+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by godesigns » Sat Mar 05, 2016 10:28 am

Tried that with no luck.

Thanks for the idea.

Newbie

Posts

Joined
Wed Jul 31, 2013 11:26 pm

Post by IP_CAM » Sat Mar 05, 2016 11:02 am

I believe, it will not function, because you added other 'stuff' into the header, making this function useless.
If it 'înternally' cannot find the correct shop-linking, certain tasks just will probably not function.
Good Luck anyway !
Ernie

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free Opencart LIGHT v.1.5.6.5_rc Software
can be seen in Action here: http://www.bigmax.ch
---
930+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by ocart777 » Sat Mar 05, 2016 11:08 am

hi, the site checkout is working fine with me, perhaps your browser javascript is turn off?
Clipboard023.jpg

Clipboard023.jpg (70.44 KiB) Viewed 535 times


You can't control the weather, but you can change your mood.
You can't modify the visage, but you can show your smile.
You can't command someone else, but you can hold yourself.
You can't forecast tomorrow, but you can using today.
You can't obtain thanks, but you can exert yourself in everything.


OCEXTENSION.COM - YOUR PROFESSIONAL OPENCART EXTENSION STORE


User avatar
Active Member

Posts

Joined
Mon Jun 10, 2013 4:57 pm
Location - Malaysia

Post by godesigns » Sat Mar 05, 2016 11:28 am

IP_CAM wrote:I believe, it will not function, because you added other 'stuff' into the header, making this function useless.
If it 'înternally' cannot find the correct shop-linking, certain tasks just will probably not function.
Good Luck anyway !
Ernie
Ernie,

Thanks for you help. Finally figured it out, it was due to having a few too many javascripts on the page.

Gary

Newbie

Posts

Joined
Wed Jul 31, 2013 11:26 pm

Post by godesigns » Sat Mar 05, 2016 11:32 am

ocart777 wrote:hi, the site checkout is working fine with me, perhaps your browser javascript is turn off?
I hate JavaScripts at times, having too many on pages make for problems.

Thanks for everyone's help.

The issue was conflicting javascripts.

Gary

Newbie

Posts

Joined
Wed Jul 31, 2013 11:26 pm
Who is online

Users browsing this forum: Google [Bot] and 53 guests