Post by _YJ_ » Wed Apr 20, 2016 5:03 am

Can someone please direct me to the mod file? I can't seem to find it. Looked in Downloads and Extensions.
ty
YJ

Newbie

Posts

Joined
Thu Apr 07, 2016 10:08 pm

Post by Randem » Wed Apr 20, 2016 5:17 am


NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by _YJ_ » Wed Apr 20, 2016 8:17 am

Thank you very much, randem.. Got it..
YJ

Newbie

Posts

Joined
Thu Apr 07, 2016 10:08 pm

Post by openweb » Thu Apr 21, 2016 12:15 am

thank you randem,
i used the files v2.1.0.x Changes.xml and v2.1.0.x Layout Fixes.xml for my web site version oc 2.1.0.1, i dont see any error now, i want to ask is there any module or file which can applay all changes from vqmod .xml files to core code directly embeded and after no need to use vqmod more? is there any module or file to make it ?

Newbie

Posts

Joined
Wed Feb 10, 2016 5:36 am

Post by Randem » Thu Apr 21, 2016 3:53 am

That is the WORST idea you can have... The whole reason behind VQMOD is so that none of the core files get changed so that if you have trouble you can easily find it by removing the XML files or by uploading a new install. In this way you don't need to keep track of ALL the places you may have changed code. You can easily remove a mod when it is no longer needed and so on... Hard coding should NEVER be used...

But if you REALLY ant to do it just take the files in the VQMOD cache and replace your original files... NOT A GOOD IDEA!!!

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by openweb » Fri Apr 22, 2016 6:19 am

Thank you randem, i understand the risk as you are right. i can use .xml files with vqmod but is there any vqmod manager or vqmod log module to see .xml files are correctly working? for example some .xml files has used in code "offset 3" line, and if my core php file or tpl file has changed by me before then this offsett line number will not work and vqmod cant find some code blocks, where i can follow the vqmod isues , bugs which cant found ?

Newbie

Posts

Joined
Wed Feb 10, 2016 5:36 am

Post by Randem » Fri Apr 22, 2016 11:22 am

I don't understand what you mean... You can use VQMOD manager to see which XML file are not being applied or are having problems with installation. If your files have been changed by you then you should have kept a record of those changes to aid in moving forward, this is where VQMOD shines. If you know where you made the changes then just make a VQMOD file to apply that change.

With VQMOD you have a record of every change, unlike changing the files yourself...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by bzark » Fri Apr 22, 2016 7:13 pm

Sorry about that. Is this vQmod error okay using the XML file from v2.1.0.x Changes file? The file is catalog/view/theme/default/template/module/account.tpl

Code: Select all

CODE: SELECT ALL
SEARCH NOT FOUND (ABORTING MOD):
  search = '<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">'

New member

Posts

Joined
Wed Oct 01, 2014 10:32 pm

Post by Randem » Fri Apr 22, 2016 7:39 pm

Are you also using VQMOD Manager? Is that where you found the error?

In the XML file this is set to ignore if it cannot make the change so in this file it is OK. All the theme template files would not need this change.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by bzark » Fri Apr 22, 2016 7:59 pm

Yes vQmod, for whatever reason it is abandoning when it hits that error and not applying any other modifications. I am using this vQmod:

http://www.opencart.com/index.php?route ... n_id=19501

It is the one suggested under Updated 02/27/2016 - v2.1.0.x Changes.zip.

New member

Posts

Joined
Wed Oct 01, 2014 10:32 pm

Post by Randem » Sat Apr 23, 2016 3:31 am

It really does NOT help if you don't answer ALL the questions...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by bzark » Sat Apr 23, 2016 3:43 am

What question didn't I answer? You said:

Are you also using VQMOD Manager? Is that where you found the error?

I said:

Yes vQmod. Sorry if I wasn't clear. I did install vQmod from that link again just to rule out I had the wrong version and it still didn't work. Very strange.

New member

Posts

Joined
Wed Oct 01, 2014 10:32 pm

Post by Randem » Sat Apr 23, 2016 4:01 am

VQMOD is NOT VQMOD Manager. If you don't use the correct terminology there will be confusion in the answer... I don't like guessing ???

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by bzark » Sat Apr 23, 2016 4:13 am

I'm assuming this is vQmod Manager as I state previously? That is what I am using.

http://www.opencart.com/index.php?route ... n_id=19501

New member

Posts

Joined
Wed Oct 01, 2014 10:32 pm

Post by Randem » Sat Apr 23, 2016 4:36 am

VQMOD for OpenCart
VQMOD Manager

Two separate and distinct pieces of software. This is why it is VERY important to use the correct terminology as I have done in an attempt to avoid mistakes, confusion and guessing. You should use both pieces of software...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by bzark » Sat Apr 23, 2016 6:11 am

Okay I will check it out and let you know what comes of it. Thanks for all your help. I also noticed in the customer_activity table that the data column contained serialized text and that new entries that were added in 2.1.0.2 weren't. Was the upgrade script supposed to unserialize that data?

New member

Posts

Joined
Wed Oct 01, 2014 10:32 pm

Post by Randem » Tue Apr 26, 2016 2:40 pm

The customer_activity table was never updated in the upgrade.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by bzark » Tue Apr 26, 2016 8:41 pm

Randem wrote:The customer_activity table was never updated in the upgrade.
Okay, I just pulled a few lines of code from upgrade.php to fix it up. Figured I would bring it to your attention.

New member

Posts

Joined
Wed Oct 01, 2014 10:32 pm

Post by Randem » Wed Apr 27, 2016 4:07 am

Thanks, I have updated the upgrade.php file to include the customer_activity de-serialization...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Pseudocrat » Thu May 26, 2016 7:09 am

How come the attached file at the bottom of the v2.1.0.x is called 2.2.0.x-CHANGES and not 2.1.0.x? Is that the wrong file or is it just compatible with either?

Newbie

Posts

Joined
Thu May 26, 2016 7:07 am
Who is online

Users browsing this forum: David Giorgi and 34 guests