Post by nurselotsaluv » Tue Jan 26, 2016 7:04 am

Hello all,

I have been playing around with Open Cart for a few months now, so I am still very green to this all. To prove that point I had my store almost ready for launch and I accidentally tried to upload a file of the wrong type in the Extension Installer which in a sense gorched some of my template files I think because it wiped the Default2 theme Extension which in turn caused many errors on my webstore pages... but I digress....

I decided to start with a fresh install (ver 2.1.0.2) and start over.

The install went smooth, I used a new suffix for my database (since I still have the gorched store on my server still for reference - is under a different root file name).

Now I go to my Extension Installer and attempt to upload the Default2 file (default2.ocmod.zip) and after 'Copying Files' I get a pop-up with the following error:

SyntaxError: JSON.parse: unexpected character at line 2 column 1 of the JSON data
OK
Fatal error: Call to undefined function ftp_connect() in /customers/2/d/c/theluvoffice.com/httpd.www/upload/admin/controller/extension/installer.php on line 292


I checked my FTP settings (the worked last night before I gorched the site) and I even re-entered them, FTP is turned on, I don't know of any settings that changed in it within the past 24 hours...

I have also tried this with another file (opencart-2-x-export-import-multilingual-2-28.ocmod.zip) and receive the same error.

Has anyone else encountered this? If so what did you do to fix it?

EDIT: I have removed the first attempt at Open Cart from my server thinking it might have been causing the error, no such luck...
I am desperate for some help.

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States

Post by nurselotsaluv » Tue Jan 26, 2016 2:20 pm

Now that I removed the original Open Cart, and the re-install, cleared my SQL database of anything linking to Open Cart, and did a completely fresh install - new database even - I am getting the same error PLUS more:

SyntaxError: JSON.parse: unexpected character at line 2 column 1 of the JSON data
OK
Fatal error: Uncaught Error: Call to undefined function ftp_connect() in /customers/2/d/c/theluvoffice.com/httpd.www/upload/admin/controller/extension/installer.php:292
Stack trace:
#0 /customers/2/d/c/theluvoffice.com/httpd.www/upload/system/storage/modification/system/engine/action.php(46): ControllerExtensionInstaller->ftp(Array)
#1 /customers/2/d/c/theluvoffice.com/httpd.www/upload/system/engine/front.php(34): Action->execute(Object(Registry))
#2 /customers/2/d/c/theluvoffice.com/httpd.www/upload/system/engine/front.php(29): Front->execute(Object(Action))
#3 /customers/2/d/c/theluvoffice.com/httpd.www/upload/admin/index.php(174): Front->dispatch(Object(Action), Object(Action))
#4 {main}
thrown in /customers/2/d/c/theluvoffice.com/httpd.www/upload/admin/controller/extension/installer.php on line 292


I didn't have these issues the first time around. I am using version 2.1.0.2 rather than 2.1.0.1 (like the first time) so maybe that is my issue....?

I'm really hoping I can figure this out, if someone can just point me in the right direction I would be most appreciated.

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States

Post by clorne » Tue Jan 26, 2016 4:14 pm

You do not say but have you tried disabling FTP and installing iSenseLabs' extension:
http://www.opencart.com/index.php?route ... n_id=18892

Active Member

Posts

Joined
Fri Dec 23, 2011 6:03 pm

Post by nurselotsaluv » Wed Jan 27, 2016 2:40 am

:yahoo:

That did it! I was at least able to get the files to upload successfully. The Import/Export extension is working, but the Default2 isn't showing up under Design, but I will dive into that later and find out what is going on (I can select it as the Theme, the design page just isn't there).

Thank you for the direction!!!

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States

Post by nurselotsaluv » Tue Feb 09, 2016 5:25 am

???

Ok... so I am having the issue again. I un-installed the iSenseLabs' extension and re-installed it (hoping it would fix the issue again). No dice. So after running into more issues I decided to start from scratch... again.... (Version 2.1.0.2)

I started by uploading the iSenseLabs' extension and then tried to install vqmod-2.5.1.ocmod.zip. This called up the same error I was having before.

So I manually added the vqmod via FTP and installed it.

Tried to use the Extension Installer again with default2v1.2.2, the error came up as

SyntaxError: JSON.parse: unexpected character at line 2 column 1 of the JSON data
OK

Fatal error: Uncaught Error: Call to undefined function ftp_connect() in /customers/2/d/c/theluvoffice.com/httpd.www/upload/vqmod/vqcache/vq2-admin_controller_extension_installer.php:292
Stack trace:
#0 /customers/2/d/c/theluvoffice.com/httpd.www/upload/vqmod/vqcache/vq2-system_engine_action.php(46): ControllerExtensionInstaller->ftp(Array)
#1 /customers/2/d/c/theluvoffice.com/httpd.www/upload/system/engine/front.php(34): Action->execute(Object(Registry))
#2 /customers/2/d/c/theluvoffice.com/httpd.www/upload/system/engine/front.php(29): Front->execute(Object(Action))
#3 /customers/2/d/c/theluvoffice.com/httpd.www/upload/admin/index.php(178): Front->dispatch(Object(Action), Object(Action))
#4 {main}
thrown in /customers/2/d/c/theluvoffice.com/httpd.www/upload/vqmod/vqcache/vq2-admin_controller_extension_installer.php on line 292


I am sure I will be able to install default2 via FTP manually... but why the heck is the Extension Installer not working for me anymore?? ???

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States
Who is online

Users browsing this forum: No registered users and 31 guests