Post by slum_x » Wed Nov 04, 2015 8:02 am

To get rid of the json parse error, which was a problem with OC 2.0.3.1 which happened when you tried to update an orders history, I have installed OC 2.1.0.1.

Now I get and Internal Server Error instead when trying to update and orders history.

My customers do not get an order confirm mail either...

I have Created an api-user an associated it with the shop.

The problem looks like it comes from this method call in catalog/order/api/order.php:

$this->model_checkout_order->addOrderHistory($order_id, $this->request->post['order_status_id'], $this->request->post['comment'], $this->request->post['notify'], $this->request->post['override']);

But I cannot find out where to find the file for $this->model_checkout_order

there is nothing in the error.log either

Newbie

Posts

Joined
Wed Nov 04, 2015 7:47 am

Post by slum_x » Thu Nov 05, 2015 1:49 am

It was a malformed translation file...

Works fine now

Newbie

Posts

Joined
Wed Nov 04, 2015 7:47 am

Post by fdarn » Thu Nov 05, 2015 2:18 am

I have been having this same problem for 2 months now. I keep asking for help but noone wants to touch this one.

New member

Posts

Joined
Mon Oct 14, 2013 8:40 pm
Who is online

Users browsing this forum: Atlantius, grgr and 27 guests