Post by belowcost » Tue Oct 06, 2015 6:28 am

I am using 2.0.3.x now, payments via PayPal standard, and I haven't been receiving shipping info on the paypal payments received after logging into paypal. PayPal shows no address OR confirmed address.

I just tried making several updates from the OpenCart forums regarding these files:

pp_standard.php
pp_standard.tpl

just tried placing an order, and still no address.

Since PayPal standard is a payment option in OpenCart, I would think there would be a pretty easy fix that someone has come across.

I did the updates as per these locations, the items that relate to 2.0.3

I just did a few test orders, and none of them come in with a confirmed PayPal address, and after logging into PayPal, PayPal doesn't show a confirmed address either.

The only place I have an address, is on the automatic email order confirmation I receive back from the Opencast shopping cart.

Why isn't this passing from the cart, through to PayPal??????? Please assist

viewtopic.php?f=113&t=46511
viewtopic.php?f=20&t=43531&p=209560#p209560

New member

Posts

Joined
Mon Sep 26, 2011 1:54 am

Post by davidbfranks » Wed Oct 07, 2015 1:23 am

I also had this issue, and was unable to find a fix on the forums.

So I purchased a premium paypal extension from the store, which did the trick.

Active Member

Posts

Joined
Mon Mar 04, 2013 10:31 pm
Location - London

Post by belowcost » Wed Oct 07, 2015 3:12 am

There has to be a solution, considering OPENCART is offering PP Standard as an option.

If there is no way to get it to work, it shouldnt be available as a payment option.

Which Premium did you purchase? If need be, PM me.

Thank you

New member

Posts

Joined
Mon Sep 26, 2011 1:54 am

Post by VictorDrummond » Wed Oct 07, 2015 11:15 am

belowcost wrote:There has to be a solution, considering OPENCART is offering PP Standard as an option.

If there is no way to get it to work, it shouldnt be available as a payment option.
Is the shop on 248 bit SHA-2 SSL cert?

Hosting for Oc 2.x: Well tested on 2.03.1 including emails work correctly, cPanel Shared or WHM VPS, managed security, fast & reliable SSD drives, Raid 10 /4 disk redundancy, server locale - Texas, contact me to discuss further.


User avatar
Active Member

Posts

Joined
Sat Dec 15, 2012 12:41 pm
Location - On the balcony slammin' Margaritas

Post by belowcost » Wed Oct 07, 2015 7:31 pm

No

New member

Posts

Joined
Mon Sep 26, 2011 1:54 am

Post by belowcost » Thu Oct 08, 2015 9:36 pm

VictorDrummond wrote:
belowcost wrote:There has to be a solution, considering OPENCART is offering PP Standard as an option.

If there is no way to get it to work, it shouldnt be available as a payment option.
Is the shop on 248 bit SHA-2 SSL cert?

No its running standard

New member

Posts

Joined
Mon Sep 26, 2011 1:54 am

Post by Qphoria » Thu Oct 08, 2015 10:37 pm

This is a not an issue with the paypal standard module. OpenCart's module passes the address correctly. All signs point to a paypal account settings issue. Check in your settings for issues related to shipping or address.. it may be your account overriding or ignoring the address it gets passed in.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by belowcost » Sat Oct 10, 2015 11:45 pm

Qphoria wrote:This is a not an issue with the paypal standard module. OpenCart's module passes the address correctly. All signs point to a paypal account settings issue. Check in your settings for issues related to shipping or address.. it may be your account overriding or ignoring the address it gets passed in.

I went to settings, and there isnt anything in PP settings that isnt allowing addresses.

I go to Order History in PP and starting back a couple months ago, PP is reporting in the customer address column "NOT PROVIDED"

Yet, when I get an email confirmation of the order, from OC, the shipping and billing address is there.

It just isnt sending or acting in cooperation to and from PP

New member

Posts

Joined
Mon Sep 26, 2011 1:54 am

Post by belowcost » Sun Nov 08, 2015 2:57 am

per paypal and i changed it, and it works do the following

In your website this particular parameter determines whether shipping should be passed or not :
<input type="hidden" name="no_shipping" value="1">
The below is the documentation for this particular variable:
Do not prompt buyers for a shipping address. Allowable values are:

0 – prompt for an address, but do not require one
1 – do not prompt for an address
2 – prompt for an address, and require one


What opencart needs to do or your developer can edit it on the Paypal module is to change to the following:
<input type="hidden" name="no_shipping" value="2">
This should now pass the address into your PayPal account.

New member

Posts

Joined
Mon Sep 26, 2011 1:54 am

Post by glolar » Tue Jul 04, 2017 10:42 pm

belowcost, your suggested fix did not work for me. I am using OpenCart 2.3.0.2.

I have looked everywhere for a fix for this problem, but none of the suggestions have worked. I have not yet seen a specific fix for OpenCart 2.3.0.2, only for earlier versions.

Any help is appreciated.

User avatar
Active Member

Posts

Joined
Thu Jul 29, 2010 12:35 pm
Location - San Diego, CA
Who is online

Users browsing this forum: No registered users and 7 guests