Post by Sea-Wing_Designs » Fri Apr 24, 2015 4:55 am

Hello,

The search bar on https://www.ornaments.com seems to have an issue. if you type in a search term, i.e. glass ornament, and click the magnifying glass, it sends you to https://www.ornaments.com/index.php?rou ... uct/search which has a search function on it, but it doesn't display any results from the original search. This means that the customer has to enter the search again, which then does return results. why is this happening?

Another minor issue is that I would expect that just hitting enter after entering text would cause the form to work, but you must click the image.

Any help would be greatly appreciated.

New member

Posts

Joined
Tue May 21, 2013 7:57 am

Post by pprmkr » Fri Apr 24, 2015 12:48 pm

Search field has wrong name!
name="Ornament Finder"
Should be called:
name="search"
Edit catalog/view/theme/yooresponsive/template/common/header.tpl and change:

Code: Select all

<input type="text" name="Ornament Finder" placeholder="Ornament Finder Search" value="" />
Into:

Code: Select all

<input type="text" name="search" placeholder="Ornament Finder Search" value="" />
After that pressing enter will also work.

Code: Select all

$('#header input[name=\'search\']').bind('keydown', function(e) {

User avatar
Active Member

Posts

Joined
Sat Jan 08, 2011 11:05 pm
Location - Netherlands

Post by Sea-Wing_Designs » Sat Apr 25, 2015 4:00 am

Thank you, that fixed it! ;D

New member

Posts

Joined
Tue May 21, 2013 7:57 am
Who is online

Users browsing this forum: No registered users and 9 guests