Post by supak111 » Sat Aug 15, 2015 9:43 am

OMG THIS NEEDS TO BE POSTED SOMEWHERE FOR EVERYONE TO SEE. AWESOME FIX!!!

Took me about a month and a half of trying to figure out why I couldn't get customers shipping address to be recorded at paypal and on my "Notification Of Payment" eMails from PayPal. I was running without seller protection for almost 6 months now and actually lost some orders to disputes! I didn't think there was a fix for this without doing PayPal Pro which costs $30 a month and requires SSL. I even went as far as trying to hire a private developer to implement some sort of fix for this! This is so easy and does work on 2.0.1.1 as well, should work on any version of OC.

THANK YOU
THANK YOU
THANK YOU!!

PS On PAYPAL you have 3 number options
I use #2 as it requires customers to pick an address there fore you ALWAYS get seller protection. With #0 may or may not get it, with #1 you NEVER GET IT! (default in 2.0.1.1)

name="no_shipping" value=" YOUR NUMBER GOES HERE "

0 – prompt for an address, but do not require one
1 – do not prompt for an address
2 – prompt for an address, and require one

New member

Posts

Joined
Fri Feb 13, 2015 12:09 pm

Post by supak111 » Tue Aug 18, 2015 9:06 am

PS. If you use #1 or #3 make sure you have shipping calculator turned OFF in paypal.com settings. If you leave the calculator ON your customer will get charged for shipping twice, once by opencarts, and once by PayPal.

New member

Posts

Joined
Fri Feb 13, 2015 12:09 pm

Post by Gamble » Tue May 03, 2016 10:53 pm

I don't have a catalog/view or a catalog/theme. This is what mine looks like, so where do I go to fix it?
I am using 2.0.3.1

Attachments

opencart.JPG

opencart.JPG (21.1 KiB) Viewed 3196 times


New member

Posts

Joined
Mon May 11, 2015 12:34 pm

Post by adambc » Tue May 17, 2016 10:23 pm

Has this changed for 2.1.x

I've tried the above fix adjusting the no_shipping value but my checkout will only properly work if I set the value to 1.

If I set the value to 0 or 2 when I try to checkout I get a paypal error page saying "The link you have used to enter the PayPal system is invalid. Please review the link and try again." But if I set the value back to 1 it will checkout without a problem.

Is there a new fix for this? Really need shipping address sent to paypal so I can be eligible for seller protection.

Any help would be much appreciated. 200+ orders have gone through without seller protection because I just can't seem to get paypal to collect the shipping info properly.

Thanks

Newbie

Posts

Joined
Tue May 17, 2016 10:19 pm

Post by parkookk » Mon Oct 03, 2016 9:42 pm

On OpenCart 2.3.0.2,
go to catalog\view\theme\default\template\extension\payment\pp_standard.tpl
edit
name="no_shipping" value="1"
to
name="no_shipping" value="2"

I see some people in here advising to change the value of no_note to fix this issue but no_note is not about shipping.

If you want the buyer to leave a note for you on the checkout then you can use the no_note and here is how:

edit
name="no_note" value="1"
to
name="no_note" value="0"

New member

Posts

Joined
Thu Jan 17, 2013 11:56 pm
Location - london

Post by benjamindemers » Thu Feb 23, 2017 5:32 am

I have applied the fix. Now how do I test to see if it is working? Should I buy a product from my cart? Please advise? Also, this is a MAJOR problem with this cart. Why is it not being FIXED so that this is not an issue OUT OF THE BOX for PayPal Standard Payments? WHY did you code the ability to choose these options OUT of this version? This makes ZERO sense! Please advise if there is going to be a fix of this issue and also how I can test if this fix listed has solved the issue. I am being charged 20 bucks on every dispute whether I win the dispute or not for returned check fees!


Posts

Joined
Tue Dec 17, 2013 5:48 am

Post by joestock » Tue Mar 28, 2017 10:50 am

After looking into this issue for version 2.3.0.2 and sending off several email messages to the techs at PayPal, we have it fixed for version 3.2. The fix is the same as listed above, however the value should be set to 2 instead of 0 like this:

<input type="hidden" name="no_shipping" value="2" /> .

in the default theme it occurred on line 40 but it could be different if your file has been edited.

The file for version 3.2 will be located in
catalog\view\theme\default\template\extension\payment\pp_standard.tpl.

Keep in mind that if you are using a theme other than the default theme, you might need to replace the default folder in the path above with the name of your theme's folder but only if this file has an equivalent in your themes folder.

Newbie

Posts

Joined
Fri Dec 16, 2016 7:25 am

Post by MTGS » Fri Jun 16, 2017 6:45 am

OMG! I have sat and read through post after post trying to find an answer to this problem. It just started out of the blue yesterday. Thanks for the fix!!! :crazy:

Newbie

Posts

Joined
Sat Sep 24, 2016 1:02 am

Post by n2rtechnologies » Sat Jun 17, 2017 1:49 am

hi
please edit catalog/view/theme/yourtheme/template/payment/pp_standard.tpl on line 40 make no_shipping value to 0.
<input type="hidden" name="no_shipping" value="0" />
I am sure it will work no..

Please contact us for support http://www.n2rtechnologies.com/

Download Free OpenCart Module.
OpenCart FREE Extensions

Hire Us and Get Free Support.
Hire OpenCart Developer


User avatar

Posts

Joined
Wed Aug 10, 2016 10:51 pm

Post by tingwing » Wed Nov 01, 2017 9:56 pm

opencart2.3.0.2,if set to "2",yes,shipping address will be sent to Paypal,but,customers can not pay by entering only paypal id and password,they have to enter a credit card at the same time.that is ,customers cannot pay by paypal depsosit. do you have the same issue as mine? thanks

my extension:https://www.opencart.com/index.php?rout ... estshop24h
email :support@bestshop24h.com
site:http://www.bestshop24h.com


Active Member

Posts

Joined
Tue Aug 02, 2016 9:01 pm

Post by RaceVTA » Thu Jun 07, 2018 12:45 am

That was easy, also works on 3.x

Newbie

Posts

Joined
Fri Apr 27, 2018 11:42 pm

Post by yancp » Sat Jan 05, 2019 10:01 pm

Can someone advise the edit should be made for 1.5.6.4 as i do not have a line with "shipping" in my pp_standard.tpl?

Is it the line <input type="hidden" name="no_note" value="1" /> i should edit to value 0?
I am not sure as i do not see how it affects the shipping address info and my problem is when country is missing from order ( i use flat rate depending on country) and order is not getting shipping cost at all.

I am also thinking to add in .tpl the line
<input type="hidden" name="no_shipping" value="0" />
but kind of uncertain if this will mess up things more

Newbie

Posts

Joined
Wed Feb 21, 2018 7:57 am

Post by ADD Creative » Sun Jan 06, 2019 3:40 am

no_note will not make any difference. no_shipping defaults to 0 anyway. You could try adding it or setting it to 2, but I'm not sure it will help with your issue.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Patternsco » Sun Jul 28, 2019 4:13 pm

HI just to tell you guys you should set field above to 2, AFTER Clear Cache! Clear OC cache its important maybe thats why so many people are not getting results

Works for OC2 and Oc 3.0.3.2 latest version to date :)

Newbie

Posts

Joined
Sat Oct 04, 2014 8:16 pm
Who is online

Users browsing this forum: No registered users and 45 guests