Post by ErickMuro » Thu Jan 15, 2015 3:35 am

Good afternoon community, I'm new to opencart; D, anyone know why the small icons appear as it should not appear?

when I am in normal page http://www.sistemasinformaticaytecnologia.com/, the icons are not displayed.

But when I'm browsing other subpages if displayed icons....

example
http://sistemasinformaticaytecnologia.c ... -flash-usb
http://sistemasinformaticaytecnologia.c ... letas-ipad

Thanks everyone

sorry using google translate ::)

Newbie

Posts

Joined
Wed Jan 14, 2015 5:10 am

Post by alexc » Thu Jan 15, 2015 4:00 am

From what I've read on the forums, it's a known bug.

The way we fixed it was to added a rewrite rule to our htaccess file to force/remove (as required) the www prefix. It's not a fix, merely a technical solution until a real fix comes out.

Newbie

Posts

Joined
Tue Jan 13, 2015 3:39 am

Post by ErickMuro » Thu Jan 15, 2015 6:07 am

It could explain how to do it? or what remove?

My htaccess its:

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase / 
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

#RewriteCond %{HTTP_HOST} ^sistemasinformaticaytecnologia.com$ [NC]
#RewriteRule ^(.*)$ http://www.sistemasinformaticaytecnologia.com [R=301,L]

RewriteCond %{HTTP_HOST} ^sistemasinformaticaytecnologia.com$
RewriteRule ^/?$ "http\:\/\/www\.sistemasinformaticaytecnologia\.com\/" [R=301,L]


Thanks Sr.

Newbie

Posts

Joined
Wed Jan 14, 2015 5:10 am

Post by dabomb59404 » Thu Jan 15, 2015 9:05 am

This should help you on what to add to it.
http://www.htaccessbasics.com/force-www-nonwww-domain

User avatar
Active Member

Posts

Joined
Thu Jun 09, 2011 5:21 am

Post by ErickMuro » Fri Jan 16, 2015 3:05 am

not working my web site :'(

whit add lines...

Newbie

Posts

Joined
Wed Jan 14, 2015 5:10 am

Post by dabomb59404 » Fri Jan 16, 2015 5:52 am

ErickMuro wrote:not working my web site :'(

whit add lines...
It looks like you added the code for it to go to your www URL. Try adding the code for it to go to your non www URL.

User avatar
Active Member

Posts

Joined
Thu Jun 09, 2011 5:21 am

Post by ErickMuro » Fri Jan 16, 2015 1:53 pm

I agree line:

# Redirect www urls to non-www
RewriteEngine on
RewriteCond %{HTTP_HOST} !^sistemasinformaticaytecnologia\.com
RewriteRule (.*) http://sistemasinformaticaytecnologia.com/$1 [R=301,L]

not working!! ???

Newbie

Posts

Joined
Wed Jan 14, 2015 5:10 am

Post by dabomb59404 » Fri Jan 16, 2015 4:02 pm

Your site is going from non www URL to www URL.
Add this below to the bottom of your .htaccess file to go from www URL to non www URL.

# Redirect www urls to non-www
RewriteCond %{HTTP_HOST} ^www\.sistemasinformaticaytecnologia\.com [NC]
RewriteRule (.*) http://sistemasinformaticaytecnologia.com/$1 [R=301,L]

User avatar
Active Member

Posts

Joined
Thu Jun 09, 2011 5:21 am

Post by ErickMuro » Sat Jan 24, 2015 7:55 am

Thanks everyone

Newbie

Posts

Joined
Wed Jan 14, 2015 5:10 am
Who is online

Users browsing this forum: paulfeakins and 30 guests