Post by emilymikl » Tue Jan 06, 2015 6:39 am

When I use an apostrophe or quotation marks in the project description, it adds a "\" or sometimes even three or more. Is there a setting or something that I can change? Or is it the font choice? I'm just using the default Open Sans for now. Any help is appreciated! Thanks!

Newbie

Posts

Joined
Tue Jan 06, 2015 2:00 am

Post by onlinemarketer » Tue Jan 06, 2015 7:21 am

Have you tried uncommenting the magic quotes line in your htaccess file?

Active Member

Posts

Joined
Sat May 14, 2011 8:21 pm

Post by allenshea » Tue Jan 06, 2015 9:10 am

onlinemarketer wrote:Have you tried uncommenting the magic quotes line in your htaccess file?

I have the similar problem, but if uncomment the magic quotes in htaccess, we will have 500 error. But we can turn off the magic quotes from php files.

Once turn off, the '\' is still there, and more others will change in database.
& into &
" into "
< into &lt;
> into &gt;
Why is that?

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by emilymikl » Tue Jan 06, 2015 9:12 am

I did that and no change. I really do appreciate the suggestion, though!

Newbie

Posts

Joined
Tue Jan 06, 2015 2:00 am

Post by onlinemarketer » Tue Jan 06, 2015 9:29 am

Here's the htaccess file that worked for me.

Maybe copy and paste it in and give it a try? Be sure to name your file .htaccess

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "((\.tpl|\.ini|\.log))">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
php_flag magic_quotes_gpc Off

Active Member

Posts

Joined
Sat May 14, 2011 8:21 pm

Post by emilymikl » Tue Jan 06, 2015 9:37 am

Yeah, now I get a 500 error :/ I fixed it, though, by adding back the .txt after htaccess. I left the magic quotes uncommented.

Newbie

Posts

Joined
Tue Jan 06, 2015 2:00 am

Post by onlinemarketer » Tue Jan 06, 2015 8:20 pm

Did you also change this section?

# Prevent Direct Access to files
<FilesMatch "((\.tpl|\.ini|\.log))">
Order deny,allow
Deny from all
</FilesMatch>

Active Member

Posts

Joined
Sat May 14, 2011 8:21 pm

Post by emilymikl » Tue Jan 06, 2015 9:25 pm

Yeah, nothin' doin', darn it. You're so good to help me! I really appreciate it!

Newbie

Posts

Joined
Tue Jan 06, 2015 2:00 am
Who is online

Users browsing this forum: No registered users and 24 guests