Post by kingofcopy » Sun Jul 21, 2019 3:43 am

Hello i have one eshop on opencart 2.0.1.1 but on invoice don't show the VAT price in totals . If you see the image from other setup show it correctly. AAhhh this problem makes me crazy. Can any body to help ?

Thanks

Attachments

11.JPG

11.JPG (29.45 KiB) Viewed 743 times


Newbie

Posts

Joined
Mon Sep 26, 2011 10:53 pm

Post by Johnathan » Sun Jul 21, 2019 5:26 am

OpenCart only shows the taxes/VAT in the "Taxes" line item on the order. If you want to change that, you could use Display Order Totals With Tax, which can change each line item to show with/without tax, or both.

Feel free to take a look at the screenshots and demo site, and if you're interested let me know at www.getclearthinking.com/contact if you have any further questions.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by kingofcopy » Mon Jul 22, 2019 5:36 am

No i need to show it on invoice after 1. sub total 2.shipping 3. need to show tax. something is wrong in my setup. i have install clean opencart 2.0.1.1 and works (see first post attached image). Please help somebody
Thanks

Newbie

Posts

Joined
Mon Sep 26, 2011 10:53 pm

Post by Johnathan » Mon Jul 22, 2019 10:07 pm

I'm not really understanding what's wrong in your screenshot. The "VAT" line item in your screenshot is the tax for the order. The calculation is correct (210.27+3.92+51.41 = 265.60).

OpenCart does not show tax in each line item, only in the one controlled by the "Taxes" Order Total. If you want to display each line item including tax you need a modification like Display Order Totals With Tax. If that's not what you mean, can you create a mockup screenshot or describe it in more detail?

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by kingofcopy » Tue Jul 23, 2019 12:43 am

The screenshot with VAT line in order Totals is from new demo clean installation opencart 2.0.1.1. This line in my old 2.0.1.1 eshop is missing. anybody how to show the VAT line in invoice order totals ?
Thanks

Newbie

Posts

Joined
Mon Sep 26, 2011 10:53 pm

Post by Johnathan » Tue Jul 23, 2019 10:09 pm

If the "VAT" line itself is missing, then you probably turned off the "Taxes" Order Total, which is what controls that line item. You can enable that in Extensions > Order Totals > Taxes.

If that's already enabled, then your tax classes are probably set up incorrectly. You can check those out in System > Localisation > Taxes, and then double-check that your products have those tax classes assigned correctly in their data.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by kingofcopy » Tue Jul 23, 2019 10:43 pm

Thanks my friend is fixed. :) :) :)

Newbie

Posts

Joined
Mon Sep 26, 2011 10:53 pm

Post by Johnathan » Wed Jul 24, 2019 10:17 pm

Glad I could help ;D

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am

Who is online

Users browsing this forum: mano.wong and 8 guests