Post by exactweb » Thu Jan 24, 2013 6:01 pm

Code: Select all

define('HTTP_IMAGE', 'http://www.opencart.local/image/');
has been completely removed from the latest Opencart and wondering why?

I found this very useful for loading images under a separate sub-domain e.g: http://forum.opencart.com/viewtopic.php?f=138&t=40573

New member

Posts

Joined
Tue May 31, 2011 5:06 pm

Post by aurevilly » Sat Feb 23, 2013 12:56 am

Really. Nobody replies to this? We're dealing with the same problem here.

We might just add it back inside the config, but an answer from the developers would be appreciated.

User avatar
New member

Posts

Joined
Thu Sep 29, 2011 4:32 am
Location - Sherbrooke, Canada

Post by Conquistadore » Tue Apr 02, 2013 7:16 am

Same here!
Is this really removed?

Newbie

Posts

Joined
Sun Oct 09, 2011 10:48 pm

Post by butte » Tue Apr 02, 2013 9:43 am

Drawing from http://forum.opencart.com/viewtopic.php?f=138&t=40573 you can presumably put it back in and see whether it conflicts with anything that might have prompted decision to remove it. You'll want to be sure that you haven't omitted any body parts and stitches.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by garuda » Wed Jun 26, 2013 2:49 am

Can anyone answer this question, or provide a link, or even a guess as to why HTTP_IMAGE was removed?

New member

Posts

Joined
Wed Apr 25, 2012 10:40 am

Post by MarketInSG » Wed Jun 26, 2013 9:19 am

If I'm not wrong, because the base codes doesn't need it anymore and he decided to remove it? You can just place it back, it doesn't harm anything.


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by butte » Wed Jun 26, 2013 9:57 am

I routinely restore it, partly because as raised to by a song long ago, "it's my teddy bear and I will if I want to," and otherwise because there will probably be vqmod usages of it that not even seeing it will trip even if it doesn't do anything any more.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Awaken » Sat Jul 13, 2013 10:55 am

To anyone like me that's been trying to setup an image subdomain, you might wanna checkout this chaps post:

http://forum.opencart.com/viewtopic.php ... 25#p397866

Attached the VQ mod here for handiness. Works a treat! You'll need to go and re-add the HTTP_IMAGE and HTTPS_IMAGE lines to both config.php files again.

For anyone using SSL on your domain (probably lots!) you might want to think laterally like I did, and point the subdomain to a subfolder of public_html. You can then have something like this:


define('HTTP_SERVER', 'http://www.yourdomain.co.uk/');
define('HTTP_IMAGE', 'http://image.yourdomain.co.uk/');

// HTTPS
define('HTTPS_SERVER', 'https://www.yourdomain.co.uk/');
define('HTTPS_IMAGE', 'https://www.yourdomain.co.uk/image/');

This won't break the padlock or green https:// when people move to secure parts of the site, images just get served from the image folder (over SSL) rather than the image.yourdomain.co.uk subdomain.

Newbie

Posts

Joined
Tue Feb 08, 2011 8:17 am

Post by arnisraido » Tue Sep 15, 2015 6:02 pm

There is one more thing left unclear: HTTP_IMAGE has been left in cli_install.php file.

https://github.com/opencart/opencart/issues/3346

But it seems, that Opencart does not use this variable, so it is not possible to use any domain alias as image link for Opencart out-of-the-box?

Newbie

Posts

Joined
Mon Aug 27, 2012 11:24 pm

Post by IP_CAM » Tue Sep 15, 2015 8:17 pm

easy to make it work again:
http://www.opencart.com/index.php?route ... n_id=23506
Ernie
bigmax.ch/shop/

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
-
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
-
1'300+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 6 guests