Post by anitawos » Wed Sep 12, 2012 1:00 am

My web hosting VPS at Arvixe was just reinstalled, and my sites are back up and working now. I am running OC ver 1.5.3.1

BUT, When I go to the admin dashboard, and select System>Error Logs I get this error message:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 123091223 bytes) in /home/myaccount/public_html/vqmod/vqcache/vq2-admin_controller_tool_error_log.php on line 43

this is line 43:
$this->data['log'] = file_get_contents($file, FILE_USE_INCLUDE_PATH, null);

This seems like it might be a setup change/error, but I am not sure what to fix/change.

User avatar
New member

Posts

Joined
Fri Jan 28, 2011 7:33 pm
Location - Massachusetts, USA

Post by anitawos » Thu Oct 25, 2012 10:33 pm

This is still broken, and still a mystery to me. Does anyone have any ideas?

User avatar
New member

Posts

Joined
Fri Jan 28, 2011 7:33 pm
Location - Massachusetts, USA

Post by pedro1993 » Fri Oct 26, 2012 6:24 am

anitawos wrote:This is still broken, and still a mystery to me. Does anyone have any ideas?
This is likely because you have a lot of errors, and it requires a lot of memory to load them. PHP by default sets a memory limit. However this is an easy fix!

In your root directory check if you have a file called "php.ini". Open that file in notepad/any text editor.

You will need to add or alter this configuration and make sure the value is 128M:

Code: Select all

memory_limit = 128M
If it still doesn't work then add this line to the admin/.htaccess file:

Code: Select all

php_value memory_limit 128M
If that still doesn't work then you should contact Arvixe and let them know, they should be able to change these settings for you :)

For OpenCart & PHP/MySQL support feel free to PM me :)
Click here for my extentions
Did I help you? Donate here to show support


Active Member

Posts

Joined
Tue Oct 18, 2011 4:31 am
Location - Glasgow, Scotland

Post by rph » Fri Oct 26, 2012 1:04 pm

Access your site by FTP and go to /system/logs/. Download error.txt if you need a copy then delete the remote version.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by jocle140 » Fri Mar 01, 2013 5:36 am

It doesnt look as though errors are appearing on my log at all anymore. Have just purposefully created several error situations whereby I am receiving fatal errors on my website page but nothing on my error log. Someone please help me!

Newbie

Posts

Joined
Wed May 02, 2012 7:11 pm

Post by rph » Fri Mar 01, 2013 8:47 am

1. Go to System -> Settings -> Edit -> Server and make sure Log Errors is set to Yes.
2. Make sure /system/logs/ has appropriate write permissions (you can try 755 or 777).
3. Make sure you're not out of space/inodes for your site.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by shafiul » Sat Jun 18, 2016 12:33 am

Wah! Why didn't I notice the error log? I'm so stupid. Thank you very much for saying the name Error Log!

The problem was with google smtp, they were not accepting my password and the problem was there! just after set it to Mail instead of SMTP, it's OK.

Thank you for taking time in replying my post.

Newbie

Posts

Joined
Sat Apr 25, 2015 6:33 pm
Who is online

Users browsing this forum: No registered users and 6 guests